Highlighted

The content you are trying to view is not supported in the current Document Mode of Internet Explorer. Change the Document Mode to Internet Explorer 9 Standards and try to view the content again. To change the Document Mode, press F12, click Document Mode

New Here ,
Apr 03, 2015

Copy link to clipboard

Copied

Hi

I am having the above problem, i have read some other threads regarding this error when running with IE 8,9. I understand this problem may be solved by publishing to both HTML5 and SWF output format.

But here is my problem, i work for a really big trust with thousands of computers that are using IE 8-9 on the all the computers and also my project is a responsive project. We are working towards responsive projects so as to facilitate staff to take courses wherever they are in order to increase the percentage compliance with their mandatory training. So when i publish my work in responsive my only choice is to HTML5 output, so when i try to run the course on our LMS i get the above (title) error message.

Does anyone has any suggestion as to what is the best way i could overcome this problem? All your advice is much appreciated.

IT WOULD SAVE SO MUCH TIME IF ADOBE COULD ALLOW RESPONSIVE PROJECTS TO BE PUBLISHED IN BOTH HTML5 & SWF OUTPUT BECAUSE DON'T FORGET A RESPONSIVE PROJECT ALSO NEEDS TO BE RUN ON DESKTOP AND THIS IS GENERALLY THE PRIMARY TARGET DEVICE AND MOBILE DEVICES ARE VIEWED AS SECONDARY IN MY CASE.

Many Thanks

Most Valuable Participant
Correct answer by Sreekanth_S | Most Valuable Participant

Even though Adobe staff visit these forums, screaming (as Lilybiri rightly pointed out) is not a way to get their attention. You can try your luck by sending them a feature request here.

https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform&product=5

Sreekanth

Views

2.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

The content you are trying to view is not supported in the current Document Mode of Internet Explorer. Change the Document Mode to Internet Explorer 9 Standards and try to view the content again. To change the Document Mode, press F12, click Document Mode

New Here ,
Apr 03, 2015

Copy link to clipboard

Copied

Hi

I am having the above problem, i have read some other threads regarding this error when running with IE 8,9. I understand this problem may be solved by publishing to both HTML5 and SWF output format.

But here is my problem, i work for a really big trust with thousands of computers that are using IE 8-9 on the all the computers and also my project is a responsive project. We are working towards responsive projects so as to facilitate staff to take courses wherever they are in order to increase the percentage compliance with their mandatory training. So when i publish my work in responsive my only choice is to HTML5 output, so when i try to run the course on our LMS i get the above (title) error message.

Does anyone has any suggestion as to what is the best way i could overcome this problem? All your advice is much appreciated.

IT WOULD SAVE SO MUCH TIME IF ADOBE COULD ALLOW RESPONSIVE PROJECTS TO BE PUBLISHED IN BOTH HTML5 & SWF OUTPUT BECAUSE DON'T FORGET A RESPONSIVE PROJECT ALSO NEEDS TO BE RUN ON DESKTOP AND THIS IS GENERALLY THE PRIMARY TARGET DEVICE AND MOBILE DEVICES ARE VIEWED AS SECONDARY IN MY CASE.

Many Thanks

Most Valuable Participant
Correct answer by Sreekanth_S | Most Valuable Participant

Even though Adobe staff visit these forums, screaming (as Lilybiri rightly pointed out) is not a way to get their attention. You can try your luck by sending them a feature request here.

https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform&product=5

Sreekanth

Views

2.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 03, 2015 0
Adobe Community Professional ,
Apr 03, 2015

Copy link to clipboard

Copied

Swf can't be responsive, as mobile devices no longer support the Flash player. Not Adobe's fault, blame Apple for that one.

The problem stems from this line in the index.htm:

<meta http-equiv="x-ua-compatible" content="IE=10">

I'm sure there is technology that is not supported in IE8, I generally run IE9 and don't have any problems.

Your only other option is to create a swf version also and redirect if IE8 or 9 and not mobile.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2015 0
Most Valuable Participant ,
Apr 03, 2015

Copy link to clipboard

Copied

If mobile devices are secondary, why don't you use a normal project and publish both to SWF/HTML?

IE8 didn't support HTML5  if my memory is correct.

And please, don't SCREAM! As David points out, you have to scream at Apple, not at Adobe for banning Flash (SWF).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2015 0
New Here ,
Apr 03, 2015

Copy link to clipboard

Copied

not screaming just UPPERCASE so adobe can pick up on this.

I understood that i may have to recreate the whole project again which would be extremely time consuming.

But i think if there was the option to publish to both it would have made life easy.

Not worthy blaming apple now coz that is past, it is easier to have an update for captivate that would allow both publishing format for responsive. This seems more like a practically possible solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2015 0
Most Valuable Participant ,
Apr 03, 2015

Copy link to clipboard

Copied

You don't seem to know that UPPERCASE = SCREAMING. And it is totally illogical to have responsive project in SWF...something you are supposed to  know.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2015 0
New Here ,
Apr 03, 2015

Copy link to clipboard

Copied

except that if it could publish to both swf/html5 today my project would run on desktop. Again the swf would help for running the desktop version of the project and mobile devices of course would pick html5.

one - what seems to you does not need to seem to me hence ur own assumption

two - I'm asking for advice and help, if you can please do if you can't no need to get personal


Thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2015 0
Most Valuable Participant ,
Apr 03, 2015

Copy link to clipboard

Copied

Even though Adobe staff visit these forums, screaming (as Lilybiri rightly pointed out) is not a way to get their attention. You can try your luck by sending them a feature request here.

https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform&product=5

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2015 0
New Here ,
Apr 03, 2015

Copy link to clipboard

Copied

Yes the SWF will then be only applicable to desktop mobile will just use the html 5 output.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2015 0
Community Beginner ,
Jul 21, 2015

Copy link to clipboard

Copied

I seem to have just run into this issue as well. I wish this had been made known to me prior to building it as a responsive project.

What's strange for me is that the course, while built responsively, works fine in IE when published without SCORM. When I publish to SCORM 2004 and upload to the LMS, I get the above Document Mode error.

Could changing to SCORM 1.2 fix it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2015 0
Community Beginner ,
Jul 21, 2015

Copy link to clipboard

Copied

I'm actually getting the error on IE 11. Weird.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2015 1
Guide ,
Jul 22, 2015

Copy link to clipboard

Copied

Overall, the issue is the version of IE you need to support.

You could run a Responsive project on desktop, if your folks had current browsers.

Unfortunately, IE 8 does not support HTML5, thus the error.

It's not really an Adobe/Captivate thing - every product has to draw the line somewhere at what 'old' technologies they'll support.

Since 'Responsive' = HTML5, a 'Responsive Project' can't work in browsers that don't support HTML5.

It would be nice if a Responsive project could publish to SWF also but since 'Responsive' is a mobile solution and mobile devices don't support the Flash Player, that limit seems reasonable.

So in your situation, options are:

1) encourage your company to upgrade everyone to IE10

2) build two versions of your project

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 22, 2015 0
Community Beginner ,
Jul 22, 2015

Copy link to clipboard

Copied

Hi Erik,

I actually spoke to someone from Adobe about this today. The problem seems to be that our LMS, SumTotal, doesn't support the IE9 standards document mode, but that's how Captivate outputs HTML5.

Unfortunately, like a lot of companies, we're tied to IE and I don't have a lot of sway over our global population to upgrade when the IT department is who manages that. Either way, it's not going to work for IE users.

I'm porting it to a blank project. Sayonara, responsive.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 22, 2015 0
New Here ,
Feb 01, 2017

Copy link to clipboard

Copied

Just a note to say I have this issue as well. The unusual part is it works inside the firewall (IE11) but external users entering through the firewall get this message. It does work in Chrome and on my iPhone as well.

The LMS is our own and the content is published to an HTML5 environment within.

I'm no expert at code but tried numerous adjustments to the index_scorm.html file but nothing worked.

I do not have the issue with content using another development software solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2017 0
Community Beginner ,
Aug 15, 2017

Copy link to clipboard

Copied

I am also using SumTotal as one of the other posts in 2015 mentioned. The issue persists in courses created with Captivate 2017 and launched through IE11. Adobe advertises that it is compatible with SumTotal, but failed to mention this really important flaw. 

What I am experiencing is that Captivate is kicking the Document Mode all the way back to IE5!

The course will play in IE if you follow the instructions to hit F12 and adjust the Document Mode to IE9 or later (I just set it to Edge). This is obviously something we don't want every person in the organization to have to do every time they need to launch a course (the settings is not retained and the issue will happen every time a course is launched in IE). 

Like others mentioned in 2015, I need it to work on all devices and it is unreasonable to have to do double work to accomplish that end. It seems to me that Adobe could move to IE 10, 11 or Edge Document Mode. 

SumTotal could do their part as well to accept IE9 Document Mode....I am addressing that with them as well. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2017 1
Community Beginner ,
Aug 21, 2017

Copy link to clipboard

Copied

Updated Information from SumTotal. You must publish as both SWF and HTML5 AND check the box Open content player in native mode (applies only to SCORM content) under the Web Based Training OptionsThis  worked for me! As for the dual publishing working with iOS. It seems to work OK on my iPad through the Sum Total app. Although you cannot publish it as responsive, i just made my blank project 1024 x 768. it scales up fine on a desktop and look fine on an iPad. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 21, 2017 0
New Here ,
Apr 06, 2020

Copy link to clipboard

Copied

Ok, so maybe I'm missing something...I'm working on a project and continually get this error.  Some background: this project came about because my customer is moving away from .swf, so I'm converting everything that *was* .swf into .mp4.  If the solution is to publish to .swf and HTML5, am I not still delivering Flash to my customer?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2020 0
Adobe Community Professional ,
Apr 06, 2020

Copy link to clipboard

Copied

When you choose the option to publish to SWF/HTML you then get the option to turn OFF the SWF output and use just the HTML5.  The push buttons that allow you to do is are often found confusing because you have to push IN the button for the output you want.  However, when the button is pushed IN it then goes darker grey in colour and this looks a little like that option is now disabled.  Not great UI design I agree.  But once you realise that you can turn off SWF completely then it works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2020 0
New Here ,
Apr 07, 2020

Copy link to clipboard

Copied

Thanks, RodWard!  I have been doing this (publish to SWF/HTML and choosing to publish to only HTML5) and still get the Document Mode error.  I'm running out of hair to pull out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2020 0
RodWard LATEST
Adobe Community Professional ,
Apr 07, 2020

Copy link to clipboard

Copied

Is this content being delivered from an LMS or are you just testing it locally in Internet Explorer?

 

If you are using an LMS, try uploading the same HTML5 content to SCORM Cloud online LMS and see if you get the same error.

 

Also, which specific browser and version of that browser are you using?  All modern browsers should support HTML5.  So this error is not something we commonly see nowadays.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2020 0