Locked

TOC not marking viewed, which does not allow the student to review already viewed slides.

New Here ,
Nov 23, 2020

Copy link to clipboard

Copied

Let me START with:

The circumstances around HOW this "quiz"/non-quiz, are being put together, can NOT be changed.

 

This is ALSO not a problem with the "quiz" completing. As far as the LMS is concerned, it gets to the end, student gets completion, all is well and good with the world.

 

The PROBLEM is that the TOC is NOT ALLOWING obviously just viewed slides, to be REVIEWED, unless the student got the question WRONG.

 

Now, no, it is NOT as simple as right/wrong answers, because of HOW the "quiz" is put together... and WHY it is put together, in this manner.

Ok. So to explain how this quiz is being put together:

 

  1. Welcome slide, Help slide, Introduction Slide, first Question Slide, correct answer slide, wrong answer slide, question two slide.... rinse/repeat the questions followed by separate slides for correct and wrong responses, till reach end, get a completion slide that sends the data, then the end slide telling student to close the "quiz".
  2. None of the slides are actually graded.
  3. ONLY the question slides, the Welcome Slide, the Intro Slide, and the Completion/Close slides, are marked as VIEWABLE in the TOC - the REST are hidden. 
  4. TOC is set to Navigate Visited Slides Only. No, they are NOT willing to change that, because they don't want the student to jump to the completion slide, and instantly get full credit without having viewed the questions.
  5. Student canNOT skip ahead. The only "psuedo" branching happening, is with which feedback is displayed post answering a question, then the resulting feedback slide goes to the "next" question.
  6. Status Flag is turned "OFF". When I turn it on for testing, I can see when it marks viewed and when it doesn't. Welcome does not mark, because it is followed by a non-TOC viewable item. However, the Introduction does, because it is followed by the first "question". This is at the very CRUX of the problem. (see attached image)
  7. So the wrong answer, is immediately followed by a viewable item on the TOC, which seems to be having an affect on why it will mark the entire "set" as viewed, if the user "sees" the wrong answer, whereas when only reaching the correct answer response, fails to trigger the TOC as the question having been viewed, as the next button for the correct response tells the timeline to skip to the next question, instead of "go to next slide".
  8. and finally, i know i know... WHY on earth are the feedback responses on separate slides?! Answer: disability readers. The reader will read EVERYTHING on the slide, including feedback if it is included. Only workaround, was to put the feedback on different slides, and then use "Jump to Slide" navigation.

 

I have gone through trying all forms of settings tweeks and advanced actions. From what I can tell, it is an issue with items being hidden in TOC, and that the TOC loses tracking if the path isn't "linear" in the hidden section. What I REALLY need, since it seems Adobe can't be bothered with a hotfix to this issue, is to find the "VIEWED" trigger command that I can force on each slide. There used to be one in the "pre" JSON version of captivate. I keep digging through mounds of documentation, and keep coming up with snake-eyes. If anyone knows the CURRENT trigger command and could share it here or in a pm, that would be most appreciated.


For the attached image: All slides up to Question 5, have been "viewed". Q1, Q2, and Q4 I answered "wrong". Q3 I answered correctly. Notice that BOTH the Welcome slide and Q3, do not have the "viewed" checkmark, and are therefore unclickable.

 

[Abuse removed by moderator]

TOPICS
Advanced

Views

38

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 24, 2020

Copy link to clipboard

Copied

No, this is not the TOC malfunctioning.

And I do know of a solution to this "issue".

But for some strange reason I cannot think of a good reason to provide it

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Lilybiri LATEST
Most Valuable Participant ,
Nov 24, 2020

Copy link to clipboard

Copied

As forum user and MVP/ACP/AEL: Totally agree with Rod, this is NOT due to TOC malfunctioning.

 

As moderator: insulting someone who has spent since many years lot of free time to help other Captivate developers just tells a lot about your attitude and is NOT appreciated. If you ever hope to get FREE help in these forums,  time to change. You probably will change your name and avatar again, since I suspect that you are NOT new to the forum.  To avoid more insults, will lock the thread.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more