Highlighted

Troubleshooting freezing on output

New Here ,
Dec 24, 2018

Copy link to clipboard

Copied

Project Details:

Captivate 2019 Release 11.0.0.243

Responsive Project

I have a project with 317 slides, about 70 of which are part of the quiz. There is branching throughout the project, both for standard content slides as well as quiz slides. The branching is controlled by conditional statements, which are part of Advanced Actions. At the start of the project, the user selects one of three narratives. This choice assigns a value to a variable. Then, throughout the rest of the content and the quiz, some slides are loaded based on the value in that variable.

There are some Animations/GIFs, and previous/next buttons on most slides, all of which have a rollover state. Because of the narrative branching, the previous/next buttons often have a Jump to Slide action.

Once I added branching to the quiz, the output both in Preview as well as Published forms began to stall. The module starts well, but after clicking through the first 50 slides or so, it begins to putter then eventually freeze completely. The approach I took to branching the content slides was working perfectly, but once I introduced it to the quiz, things took a turn.

I would appreciate any insights as to why the output is stalling. Have I created too large or complex a project? Is there a better approach to branching?

Happy to provide more details about any part of the project. It feels a bit like a needle in a haystack and my Captivate troubleshooting experience is limited so I'm not sure what the culprit(s) is.

Thanks!

Views

179

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Troubleshooting freezing on output

New Here ,
Dec 24, 2018

Copy link to clipboard

Copied

Project Details:

Captivate 2019 Release 11.0.0.243

Responsive Project

I have a project with 317 slides, about 70 of which are part of the quiz. There is branching throughout the project, both for standard content slides as well as quiz slides. The branching is controlled by conditional statements, which are part of Advanced Actions. At the start of the project, the user selects one of three narratives. This choice assigns a value to a variable. Then, throughout the rest of the content and the quiz, some slides are loaded based on the value in that variable.

There are some Animations/GIFs, and previous/next buttons on most slides, all of which have a rollover state. Because of the narrative branching, the previous/next buttons often have a Jump to Slide action.

Once I added branching to the quiz, the output both in Preview as well as Published forms began to stall. The module starts well, but after clicking through the first 50 slides or so, it begins to putter then eventually freeze completely. The approach I took to branching the content slides was working perfectly, but once I introduced it to the quiz, things took a turn.

I would appreciate any insights as to why the output is stalling. Have I created too large or complex a project? Is there a better approach to branching?

Happy to provide more details about any part of the project. It feels a bit like a needle in a haystack and my Captivate troubleshooting experience is limited so I'm not sure what the culprit(s) is.

Thanks!

Views

180

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 24, 2018 0
Adobe Community Professional ,
Dec 25, 2018

Copy link to clipboard

Copied

You are not currently using the very latest build of Cp 2019.  So the first step in your fix for this issue should be to update your install of Captivate to the latest minor version and then see whether that resolves the issue.  If it doesn't, we can look at other possibilities.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 25, 2018 0
New Here ,
Dec 25, 2018

Copy link to clipboard

Copied

Hi Rod, thanks for the idea. It looks to me as though 11.0.0.243 is the latest stable version. At least that's what I'm seeing around the web and there's no visible way to update the version through the usual means — typing "Check for Updates" into the Help menu, or anything elsewhere under the Adobe Captivate menu. This article (Adobe Captivate Help | Adobe Captivate (2019 release) Update 1 Release Notes) would suggest there is a more recent version (11.0.1), but I'm not seeing it available through the Captivate UI. Is there somewhere else to get a bleeding edge version?

Thanks for your time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 25, 2018 0
Most Valuable Participant ,
Dec 26, 2018

Copy link to clipboard

Copied

You do not have the most recent release. I suspect you are a Mac user. In a staff blog it is mentioned that you should first uninstall the hotfix which got you to your present version (Mac only) and then install the patch to 11.0.1.266 which is the most recent version. If I find that blog in the portal, I will post a link.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 26, 2018 0
New Here ,
Dec 26, 2018

Copy link to clipboard

Copied

Hi Lilybiri, thanks for chiming in. I am indeed a Mac user. If you can find that blog post, or a page of version downloads, that would be fantastic! I suppose that might be the equivalent of the Creative Cloud apps page, or even where I would expect a download repository on my Captivate Account page:

Screen Shot 2018-12-26 at 8.43.33 AM.png

The Download link there goes to the previously hyperlinked Creative Cloud apps page, and there's nothing to be found under the Adobe Captivate section.

I haven't installed any hotfixes to get me to my present version as of this point. I purchased and downloaded the program for the first time in early November and as far as I know, no updates have been pushed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 26, 2018 0
Most Valuable Participant ,
Dec 26, 2018

Copy link to clipboard

Copied

Sorry, have been searching but only found this:

Captivate (2019 release) Update 1 is now live! - eLearning

The patc was released in October, strange that you didn't have the most recent version. There is no application luke CC manager for Captivate, updates are NOT pushed, you have to install them, using Help, Updates. I ama Windows user, reason why I am hesitatnt to pop in on trheads by Mac users.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 26, 2018 0
New Here ,
Dec 31, 2018

Copy link to clipboard

Copied

Thanks for finding that link, @Lilybiri. I have now upgraded to 11.0.1.266. I do indeed use a Mac. Still, it's odd that I didn't get that version when I downloaded the program the first time.

The problem is no better, though. The export still stalls as much as before.

RodWard​ now that I'm on the latest minor version, do you have any insights?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 31, 2018 0
Adobe Community Professional ,
Dec 31, 2018

Copy link to clipboard

Copied

Your project is quite large and complex.  My initial thought would be that you may find you perhaps have some corruption, or else there are too many buttons or other interactive objects.  I had another user with a project last week that had hundreds of buttons (for the navigation) and his project was also stalling.  It turned out that once he removed half the buttons then it worked.  You might try taking a copy of your project and then experimenting with simplifying it to see if that would resolve the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 31, 2018 0
New Here ,
Dec 31, 2018

Copy link to clipboard

Copied

Alright, I'll clone the project and make a version with less complexity, then report back with the results. The buttons are often necessary to continue viewing the module, but I can try removing hover states, animations and any other flourishes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 31, 2018 0
New Here ,
Jan 09, 2019

Copy link to clipboard

Copied

Update: removing rollover states on buttons, animated GIFs, and certain navigation buttons had a noticeable effect, but ultimately the module would still freeze, albeit slightly further along.

I removed the quizzes entirely and separated each quiz into its own Captivate project.I conditionally link to the quizzes from the primary module. Freezing isn't an issue anymore, but the downside is the project is less maintainable since it is spread across 4 Captivate projects.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 09, 2019 0