Highlighted

Variable communication between Captivate HTML and Connect LMS (or lack of)

New Here ,
Dec 13, 2018

Copy link to clipboard

Copied

I use Captivate 2019 to author and a Connect server owned by my company as the LMS.  All output is now HTML5 for security reasons with flash.

I'd like to capture something as seemingly simple as the user's ID from the LMS but it's not happening.

Connectusers.com seems to be a pretty dead forum now but there was a person who had the same problem I do: Adobe Connect User Community

In that thread was a pointer to how to create a flash certificate that gets auto-populated with name, course, certificate number...all from Connect variables and listed those variables.  I created a flash certificate based on that some years ago, it works great....but its flash.

Using those same Connect variables in Captivate, I get no response at all in an HTML5 project.  In fact, for the Captivate variables for Student ID or Name, no response.  Not sure if I'm doing something wrong, the server needs something done to it, or....?

Would greatly appreciate some help with this.

I created a simple project to display a ton of variables:

project.png

Published it to my server, assigned it as curriculum, and here's the output:

output.png

The project file is available from https://goo.gl/Y4J49t

Views

95

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Variable communication between Captivate HTML and Connect LMS (or lack of)

New Here ,
Dec 13, 2018

Copy link to clipboard

Copied

I use Captivate 2019 to author and a Connect server owned by my company as the LMS.  All output is now HTML5 for security reasons with flash.

I'd like to capture something as seemingly simple as the user's ID from the LMS but it's not happening.

Connectusers.com seems to be a pretty dead forum now but there was a person who had the same problem I do: Adobe Connect User Community

In that thread was a pointer to how to create a flash certificate that gets auto-populated with name, course, certificate number...all from Connect variables and listed those variables.  I created a flash certificate based on that some years ago, it works great....but its flash.

Using those same Connect variables in Captivate, I get no response at all in an HTML5 project.  In fact, for the Captivate variables for Student ID or Name, no response.  Not sure if I'm doing something wrong, the server needs something done to it, or....?

Would greatly appreciate some help with this.

I created a simple project to display a ton of variables:

project.png

Published it to my server, assigned it as curriculum, and here's the output:

output.png

The project file is available from https://goo.gl/Y4J49t

Views

96

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 13, 2018 0
Contributor ,
Dec 13, 2018

Copy link to clipboard

Copied

I know absolutely nothing about Connect or how their variable hook in with Captivate, but the first thing I do when problems occur is open the Console panel in the browser to look for errors on the page. Have you tried that?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2018 0
New Here ,
Dec 13, 2018

Copy link to clipboard

Copied

A couple warnings, no errors:

warnings.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2018 0