Highlighted

XML import doesn't work

Community Beginner ,
Dec 11, 2019

Copy link to clipboard

Copied

I have exported an XML file from my captivate project for translation purposes and now when I try to import it back into the project, it doesn't work and I get the message "cannot import".

 

I notice that this has been happenning for years.  Does anyone have any solutions?

TOPICS
Import export

Views

99

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

XML import doesn't work

Community Beginner ,
Dec 11, 2019

Copy link to clipboard

Copied

I have exported an XML file from my captivate project for translation purposes and now when I try to import it back into the project, it doesn't work and I get the message "cannot import".

 

I notice that this has been happenning for years.  Does anyone have any solutions?

TOPICS
Import export

Views

100

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 11, 2019 0
Most Valuable Participant ,
Dec 11, 2019

Copy link to clipboard

Copied

Did you edit the cptx file or rename it after having exported the XML file? Did you rename the XML file? 

Which version are you using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019 0
Community Beginner ,
Dec 11, 2019

Copy link to clipboard

Copied

The text in it was translated, only. The file has not been renamed and i am using the latest version.

This is the same issue that has been posted for years, without any fixes.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019 0
Community Beginner ,
Dec 11, 2019

Copy link to clipboard

Copied

We have now discovered the issue. When exporting an XML file from captivate it adds in syntax errors, which then prevents the import back in. 

 

We discovered this by using a debug tool on the exported file (that had not had any edits etc) and we found that the following characters were added in at various points "" as a result you then get issues when trying to import the file back in again.

 

As this is clearly a fault within captivate, I would advise adobe rectify this issue in the next update, to prevent users encountering this going forward.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019 0
Most Valuable Participant ,
Dec 11, 2019

Copy link to clipboard

Copied

This is a user forum, please post a bug report if you want to be heard.

Here is link to the form:

https://adobe.allegiancetech.com/cgi-bin/qwebcorporate.dll?Y9CHVD

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019 0
Community Beginner ,
Dec 11, 2019

Copy link to clipboard

Copied

Bug report has been posted, but it is valid to put the reason for error and solution for every user out there, in this forum.

 

Especially if adobe won't deal with the issue, which would appear to be the case, as this has been highlighted since captivate version 6, going by the various forum questions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019 0
RodWard LATEST
Adobe Community Professional ,
Dec 11, 2019

Copy link to clipboard

Copied

Thank you for doing the extra work to locate the source of the problem.  It all adds to the knowledge and helps solve the problem for others.

 

One question I have:  If Captivate is adding in these codes, my guess is that it is doing so to replace some other characters that are regarded as 'illegal' or not allowed for some reason.  Are you able to tell us what those might be?

https://en.wikipedia.org/wiki/List_of_XML_and_HTML_character_entity_references

 

If we could isolate what the original characters were, that would allow users to avoid them in the text captions and closed captioning so that this issue did not occur.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019 0