Adobe Monitor/NDI weird behavior

New Here ,
Aug 12, 2020 Aug 12, 2020

Copy link to clipboard

Copied

Tearing my hair out on something I can't find any other users dealing with-- my puppets work perfectly in the app and can mirror to another screen (Adobe Monitor) or other PC with NDI. However.. in the monitor or NDI (happens in both, tested individually), animations tend to hold between input.

 

For instance, an auto blink looks perfect in the application, but on the streamed output, the blink activates, closes the eye but then stays in that status until more input (such as voice or the next auto-blink triggers) at which point it works fine until input stops for a moment. It's crazy seeing it perfect in my timeline/application and not showing the same thing on the other screen/stream. If it's supposed to mirror the application, I can't wrap my mind around how the output doesn't match, even locally to just another monitor.

I've attached a screen shot across all monitors (same moment in time) and combined for viewing. Any thoughts/ideas?

TOPICS
Bugs , Freeze or hang , Puppet movement

Views

214

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 02, 2020 Nov 02, 2020
Sorry to hear about the problem. I could repeat the problem when I'm using Auto Blink. If you are seeing this with Auto Blink, could you try to set Blink Duration to shoter? For me, the problem stops with Blink Duration 40ms or less for 24 fps scene. Hope this helps.

Likes

Translate

Translate
Adobe Employee ,
Nov 02, 2020 Nov 02, 2020

Copy link to clipboard

Copied

I'm asking the development team - I'll let you know if I hear any feedback. This is really strange.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2020 Nov 02, 2020

Copy link to clipboard

Copied

I really appreciate that! As a workaround for the time being I hooked up a separate webcam so there is constant input refreshing with eye tracking, but this is still pretty cumbersome. My use case is niche enough that I can deal with this (most people would want the puppets tracking etc, not just auto blinking with no eye movement) but the behavior was odd enough that it really threw me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2020 Nov 02, 2020

Copy link to clipboard

Copied

Sorry to hear about the problem.

I could repeat the problem when I'm using Auto Blink. If you are seeing this with Auto Blink, could you try to set Blink Duration to shoter? For me, the problem stops with Blink Duration 40ms or less for 24 fps scene.

Hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2020 Nov 02, 2020

Copy link to clipboard

Copied

Thank you. This solves the problem immediately at 40ms blink. I did some trial and error at scaling that with higher/lower fps but didn't see an impact. It isn't perfect for me because my puppets are very simple and a longer blink is part of a design decision, but it's absolutely a workaround. Knowing the team is aware of this is awesome and I appreciate you looking into it! For now I have a solution, thanks again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 03, 2020 Nov 03, 2020

Copy link to clipboard

Copied

LATEST

There is the better way, using cycle layer, from the team.

 

Steps

1) Prepare sequence layers (I used blank 3 frame png sequence).

2) File -> Import Cycle.

3) Open imported png puppet in Puppet panel. Cycle Layer behavior is applied as default.

4) Set Cycle Layers -> Cycle to Continuously.

5) Place png puppet (Cycle Lyaers) to your scene.

 

With this workaround, I can use any Blink Duration. 

Please try this workaround.

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines