And once again, i am totally lost editing a puppet at all.

Community Beginner ,
Jun 01, 2020 Jun 01, 2020

Copy link to clipboard

Copied

okay, 

I had downloaded one of the free puppets offered on the site.

its name is templateman.

I have had zero luck editing him at all. I have watched the videos, and followed the instructions with zero luck.

I will attempt to load my screen shots so it seems legible.

I start the program with the puppet, he is movable, and can have movement triggers. (1st picture)

I origionally wanted to add a gotee, but for simplicity i decided to show what happens when i just want to delete the logo on his shirt.

I go from record screen to rig screen, and this is what i get (picture 2) I click edit oriogional (pic 3) and it opens adobe illustrator (pic 4) and this is how it starts. (pic 5) shows exactly how the program starts. you can see I deleted the layer with the logo. I follow the instructions and click save (pic 6) which gives me a default area to save the character to (pic 7). after that i get the deafult illustrator option (pic 8) which i click ok. (pic 9) shows absolutely nothing changes as shown in the videos and adobe instructions. so i followed another set of instructions which says to import the saved character i just changed (pic 10). and lastly (pic 11) shows what i get. a dead picture with no movement at all. I even tried adding drag points with zero luck. it just becomes a picture of what rezembles a multi armed picture.  what is my issue here? I cant get it to works at all??? I have tries several different puppets, and same deal. I have also tried hiding the extra apendages before i bring the charachter into illustrator. same issues..

Screenshot (18).pngScreenshot (20).pngScreenshot (21).pngScreenshot (23).pngScreenshot (24).pngScreenshot (25).pngScreenshot (27).pngScreenshot (28).png   

TOPICS
How to , Puppet movement , Rigging

Views

859

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 01, 2020 Jun 01, 2020

Copy link to clipboard

Copied

Hi. The screenshots are a little blurry, but when you do edit original, it looks like you are doing "save as" and saving your changes in a new file, rather than using "save" to update the original file. You *must* update the original file, not create a new one.

 

Dont import the artwork (illustrator file). That will loose all the character animator rigging. A .puppet file includes the artwork and rigging.  Both are needed.

 

Once you use "Save" instead of "Save As" it should start working. You should not be asked to provide a filename when saving the file. As soon as you are, something has gone wrong. Either you are doing "Save As", or the file is read-only and cannot be updated, etc.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 01, 2020 Jun 01, 2020

Copy link to clipboard

Copied

Just to expand slightly, when you "Save", wait a second then go back to Character animator. It should notice that the artwork file was updated and refresh automatically. This only works when files are on the local file system (not on a network drive). If you save to a new file, CH won't see your changes because it is watching the original file for changes (it is not looking for new files in the same directory as the original file).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2020 Jun 02, 2020

Copy link to clipboard

Copied

Hi,

Thank you for the responses.

I just did it again and made sure it was "save" and not "save as".

It is deffinitely "save".

that then does open the page of ateempting to name, and so on............

 

The only reason i had to import was because when i done saving, the origional file in the open Charcter animator never ever changed.

 

Do you have any other thoughts?

Im definitely at an impass. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2020 Jun 02, 2020

Copy link to clipboard

Copied

Okay.

I figured something out.

with the PC at work, when you go into RIG and then click "edit origional", it opens in Photoshop and everything works perfectly.

when i use the PC at home (the one i was using yesterday), and hit "edit origional" it opens in adobe illustrator, and i have all of the problems.

Im not sure why this happens.

How can i get it to automatically open in photoshop?

 

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 02, 2020 Jun 02, 2020

Copy link to clipboard

Copied

Wow! It opens illustrator on a photoshop file? Funky! Do you have photoshop installed? Maybe that is the fallback it is using.

 

Step one: If you single click on the puppet in the project panel (usually top left) then look at the properties panel (over on the right) the first property should be Path. Does this end in .psd?

 

Next, open up Windows explorer and go to the directory where the file is. Double click on it. Does it open up Photoshop? If not, uninstall photoshop and reinstall it. This can sometimes fix up the file extension bindings. (There may be some cleverer way to do this, but I don't know what it is!!) Then try agin to double click on the file. Then use "Save" and make sure that works.

 

Once the above works, try again from Character Animator. See if that has fixed the problem. "Edit Original" mimics double clicking on the file for you, so if Windows has associated the wrong program with the file extension you would get that problem. Illustrator probably converted the PSD file into an AI file, which is why "Save" is asking for a filename - it cannot update the original file because it changed the format!

 

You can tell Character Animator to use the new AI file, but it might lose all the rigging in the process so I don't recommend it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2020 Jun 02, 2020

Copy link to clipboard

Copied

LATEST
Thank you very much for all of the help. I do have photoshop installed, and the file did end with .psd. so that got the wheels turning. I found that all the psd files were associated with .ai to open. I changed it, and EUREKA! it worked! Thank you very much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines