Arm IK stretchiness controls stop working within a swap set of arms.

Community Beginner ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

I have a puppet with arms with swap sets. I found this works better for arms with various hand gestures as hands in their own folder move with the arm but can be floppy and hard to control. Problem is with arm IK enabled I can limit stretchiness. But with the swap set it does not work. Placing arm IK on each variant doesn't work either. Is there a workaround or is there a way to make hands in a swap set in their own folder stay rigid when they move with the arm when it is dragged? Thanks.

TOPICS
Puppet movement

Views

69

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

If you're using Arm IK, it sounds like you're using an older version, as the behavior changed name to be Limb IK in more recent versions. So first I'd recommend updating.

 

You should be able to either apply Limb IK to each group (for independent parameter control), or, if you want identical parameters for all triggered groups, you could apply Limb IK once at the root and make sure each arm group has a view tag like (like Frontal — you can apply the same view tag for all of them). Limb IK will then treat each view as a separate grouping of limb tags.

 

Sounds like you already tried applying Arm IK to each group, so maybe there's something else confusing it. If upgrading and/or the view thing doesn't help, sharing a hierarchy screenshot (or the puppet itself) could help us diagnose.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 25, 2022 Jan 25, 2022

Copy link to clipboard

Copied

Thanks for your response. I am on the current version I just choose 'arms' rather than both arms and legs. I'll get back to this I have a more serious issue wherein a walk cycle malfucntions and the arms movedown, I'm posting seprately about that as to not be confusing since that wasn't the topic here. Presently I stripped the rig down so the other issue is moot for a while. Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

Yay got the other stuff resolved and back to the arm IK issue. I've tired applying the arm IK to the indivdual swap layers for the arm as well as the root but itmakes no difference. I just want the strechiness off or way down. You can see the way it's rigged, there is no effect in the stretching, Any ideas?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

Oh should mention the shoulder tag is on the body, the elbow and wrist are on the arm, which is working fine with movement and such. Tagging the shoulder on the arm as well had no effect, thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Instead of separate handles for Right Wrist and Draggable, have you tried having a single handle that is tagged with both?

If that doesn't work, and you're willing to DM me with a link to the .puppet file, we'll take a look here at the factory.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2022 Feb 04, 2022

Copy link to clipboard

Copied

Sorry for the delay in getting back, was down with a nasty cold. Luckily not Covid. Oddly when I opened the rig and went to record mode the app then put up an error message about a non-commited change to the IK. Which I deleted and reapplied and now it works. Not sure what that meant but hey it's working now so I'm not going to stress about it. Thanks for your input!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 04, 2022 Feb 04, 2022

Copy link to clipboard

Copied

LATEST

Glad to hear you got it working!

 

If you have a moment, that error message should have been saved in <projectfolder>/Ch Data/errors-by-oid.log — could you share it here?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines