Audio tracks are out of sync when recording in Character Animator (latest update v3.2)

Community Beginner ,
Apr 09, 2020 Apr 09, 2020

Copy link to clipboard

Copied

Hey guys, I'm having this issue with Character Animator where the two tracks which show audio waves are out of sync with each other. It ruins the entire recording and it only started after I updated from beta. It creates a sort of echo effect to the recording. 

 

See attached image for visualization of the issue. Anyone else experiencing this? 

 

https://i.imgur.com/KVIexoi.png

TOPICS
Bugs

Views

2.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , May 20, 2020 May 20, 2020
We only recently ran into this problem at the factory here. Once we could reproduce it, we discovered it’s caused by being zoomed in on the timeline while recording. Easy workaround: zoom out the timeline before recording. Sorry that won’t be of help to your existing recordings. Here are some steps to fix them in Audition by converting them to mono (don’t mix the channels together, just take a single channel): find the bad audio in the project panel inside the Recordings folder right-click ...

Likes

Translate

Translate
Adobe Employee , May 26, 2020 May 26, 2020
Thank you for the additional information.  We are testing a fix for this and hope to release it in an upcoming update.  

Likes

Translate

Translate
Community Beginner ,
Apr 11, 2020 Apr 11, 2020

Copy link to clipboard

Copied

Alternatively if there is a way to move the tracks to line them up that would also be nice to know... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 17, 2020 Apr 17, 2020

Copy link to clipboard

Copied

Still not solved.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 18, 2020 Apr 18, 2020

Copy link to clipboard

Copied

..

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 18, 2020 Apr 18, 2020

Copy link to clipboard

Copied

What does this wave look like in Adobe Audition?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 15, 2020 May 15, 2020

Copy link to clipboard

Copied

Add me to the list of people having this issue. I believe I have it narrowed down to an issue specific to Character Animator, and possibly a workaround. To restate the issue, recordings I make with CA result in audio files where the L and R channels are slightly out of sync; just enough to make the recording useless. 

 

Picture 1 shows the take in Adobe Audition. (I right-clicked on the take in CA > revealed in project > revealed in explorer > opened with Audition, thus making sure to open the bad take.)

 

Picture 2 shows a recording I then made directly into Audition to demonstrate here that my mic works just fine everywhere else. I have not had any issues with it in any other Adobe apps since before and after the latest updates. I also regularly use other brands of apps to stream and record with no issue.

 

Throughout my testing, I discovered that sometimes Take 2 in the timeline will record perfectly in sync. Take 1 *always* defaults to asynchronized channels. Sometimes Take 2 is fine.. and sometimes even every take therafter is fine. However, it seems pretty random from project to project. Definitely not reliable enough to consider using Take 2+ as a workaround.

 

=== WORKAROUND? ===

 

HOWEVER, I also discovered that toggling the frame rate in the properties window sets things right for the duration of a project. Changing from 24 fps to 30 works. Changing from 24 to 30 back to 24 works. No need to record between changes.

 

Upon opening a new project, Take 1 still always defaults back to asynchronized channels. However.. if you open a new project and toggle the frame rate prior to recording Take 1, that seems to do the trick. 

 

I've tested this across 4 or 5 new projects, creating a new scene within a couple. of them. So far, this feels like a solid workaround. If I determine otherwise, I'll come back to edit this post. I hope anyone else who finds success with this will say so. I can never feel too confident about a workaround. 🙂

 

Conclusion/Theory: Some piece of code under the hood is using bad math upon instantiation, and resetting the frame rate resets some common variable. My OS version is pasted below. I actually updated it last night as part of troubleshooting. 

 

A forum admin or employee may feel free to report this as a bug. That's a road I've wasted too much time going down over the years. I just want fellow dead-in-the-water creators to know they're not alone & that maybe I found a workaround. Cheers!

thefuzie_2-1589597962981.png

 

thefuzie_0-1589592185852.png

 

thefuzie_1-1589592483883.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 16, 2020 May 16, 2020

Copy link to clipboard

Copied

I'm having the same problem with out of sync audio. Channel one audio is a few frames ahead of channel two audio. Here is a screengrab of my current project.

 

Expanded view of waveformExpanded view of waveform

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 20, 2020 May 20, 2020

Copy link to clipboard

Copied

Is there any way to fix an out of sync audio track recording? I thought I worked around it but an hour of very important audio is out of sync. It would be a huge pain to redo it now. Any way to remove one of the 2 tracks? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 20, 2020 May 20, 2020

Copy link to clipboard

Copied

I have no idea why it is happening or how to solve it. Some last resort ideas just to get the project done until a real solution comes along.

 

Do you need stereo? Maybe edit the audio track in Adobe Audition and turn into a mono recording. They cannot get out of sync with each other if there is only one of them!

 

Another approach is to strip the audio from CH (other than using it for lipsync calculations) and add it back in using Premier Pro or similar. Yucky, just trying to think of workarounds until a real solution is found.

 

The other approach is to try something like click on the audio clip in the Project panel (it might be inside the "Recordings" folder). Over on the right in the properties panel it should show the path name to the file. If you click on the path name you can update it to point to a new filename. Try pointing it to a different file and then point it back at the right file. Does it come good then?

 

If you edit the raw file in Adobe Audition, are the tracks out of sync in the original file? (I am guessing not - that would be pretty strange to have happen.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 20, 2020 May 20, 2020

Copy link to clipboard

Copied

We only recently ran into this problem at the factory here. Once we could reproduce it, we discovered it’s caused by being zoomed in on the timeline while recording. Easy workaround: zoom out the timeline before recording.

 

Sorry that won’t be of help to your existing recordings. Here are some steps to fix them in Audition by converting them to mono (don’t mix the channels together, just take a single channel):

  1. find the bad audio in the project panel inside the Recordings folder
  2. right-click on it and choose Reveal in Finder/Explorer
  3. quit Ch
  4. open the file in Audition
  5. select-all (cmd/ctrl-A)
  6. right-click on the selected waveform and choose Extract Channels to Mono Files
  7. select the new L & R files in the Files view and save them somewhere
  8. go back to the folder that was revealed in Step 2
  9. rename the file to something else (e.g. XXX_orig)
  10. pick either the L or R mono file and place it next the XXX_orig file (in the same folder)
  11. rename the mono file to exactly the old XXX name so Ch will find it instead of the stereo file
  12. relaunch Ch

 

If preserving the stereo signal is important, you could instead shift one of the channels so as to align them, and re-save. I can get an Audition expert to explain how to do that if needed...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

Life saver! I was able to restore my recording back to normal from that awful echo. This helped a TON. Thank you thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

See new post.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

Try setting your audio sample rate to 48000 instead of 44100.  Does that solve the issue?  (See Preferences->Audio Hardware)

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

Will test right now.


See also my post near the top of this thread. You can pretty much toggle the framerate any way you want to workaround the issue. You can toggle to 48000 and back to 44100, without recording anything, to resolve the issue. 

thefuzie_0-1590112885479.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

Yup. Changing sample rate also did the trick. I have to click into the Windows control panel to change input settings, so the framerate toggle is a simpler solution for me. 

 

I will click around on some other things. It almost seems like this is just some bizarre issue where the first take timeline is offset through a bad variable & then changing any related option just resets it with the right variable.

 

You might do well to search up a second instance of the code via some common text outside the variables in the instantiation code. Then run and compare them both. Figure out why the variables differ. Just going on gut.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

Edit: Yah, so changing any of the 4 numeric properties in the properties panel, except for duration, also seems to do the trick. When a new value is set for any of those variables, the Take 1 timeline variables are corrected.

 

foo.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 26, 2020 May 26, 2020

Copy link to clipboard

Copied

Thank you for the additional information.  We are testing a fix for this and hope to release it in an upcoming update.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 16, 2020 Jun 16, 2020

Copy link to clipboard

Copied

LATEST

This problem has been fixed in Ch 3.3.1, released last night.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines