• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Blending recording takes - NOTHING is working per instructions/Adobe youtube tutorials

New Here ,
Jul 13, 2020 Jul 13, 2020

Copy link to clipboard

Copied

I really don't know what I'm doing wrong and would love some help.  The only thing I've been able to successfully blend in multiple takes is head movements.  If I record arm movements and place over a previously recorded walk cycle, the arm movements don't show up in playback.  They do if I hide the walk layer.  I think I can understand why this might be - it's a 3-view puppet, so when I'm manipulating the arms, I'm doing it to the frontal version, not the right profile version seen during the walk.  So I figured I would export the puppet, import it as a new puppet into the software and then delete out the other views, leaving ONLY right profile.  Not only did this not work (arms were locked?!?)  it also seemed to delete these two views from my master puppet also, so I had to undo all of that.   Every intuition I have about how this should work is wrong!

 

Another thing I'd like to do is mix walk styles.  For instance - I'd like the character to walk, then strut for a few seconds, then go back to walk.  I recorded a steady walk.  Then recorded a short strut and tried to drag over and use blending handles.  Doesn't work.  It only plays back the walk style that is selected during playback, ignoring what was seleted during recording. 

 

From every Adobe youtube tutorial I've viewed, the way I'm doing all of this seems like it's exactly right and should work.  I've been using Adobe products for 20+ years (Primarily a Premiere/After Effects editor).  I CAN NOT figure out how to make this software work for me. 

 

FYI - here is the puppet I'm working with.  It was all pre-rigged and ready to go: 

https://graphicmama.com/character-animator-puppet/rita-heels

TOPICS
How to , Puppet movement

Views

168

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 13, 2020 Jul 13, 2020

Copy link to clipboard

Copied

RE: If I record arm movements and place over a previously recorded walk cycle, the arm movements don't show up in playback.

 

I assume arms are animated by Dragger.
If so, this puppet has Draggable handle only on Frontal view. But Walk happens in Right or Left view. So that your recorded takes for arm animation is not visible while walking.

To work around this, you can add Draggable handles to arms in Right or Left views, and animate them in that view.

 

Here is steps for Left profile (you can do same in Right profile).

First, add Draggable tags
1) Open "rita-advanced" in Puppet panel.
2) Double click and open "left Profile"
3) Add "Draggable" tag to "arm2" and "arm1"

Next, to animate arms in Left view, need a create a swap set to set view.
4) Go back to show "rita-advanced" in Puppet panel.
5) In Triggers panel, select "Create Swap Set"
6) New swap set add "Frontal", "left profile" and "right profile"
7) Assign key. e.g. L for "left profile".
8) Set "Frontal" to default of this swap set.
9) Go back to Record mode.
10) hit L to show "left provile" (Left view).
11) Record arm animation in Left view.
12) Record Walk animation with left arrow.

Then "rita-advanced" has arms at step 11 while playing recorded walk from step 12.

 

I hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 13, 2020 Jul 13, 2020

Copy link to clipboard

Copied

RE: I'd like the character to walk, then strut for a few seconds, then go back to walk.

 

I don't see blending handle for Walk Style, but I can switch Walk Style while walking.

To do so, please make sure Walk -> Walk Style is armed before recording.

 

Steps
1) Select "Enable Parameter Recording" from "..." next to Walk Style.
2) Set Walk Style = Walk
3) Record and stop.
4) go back to time where you want to change the style.
5) Set Walk Style = Strut
6) Record and stop.
You will have 2 take bars of Style in Timeline.
When you playback, you can get different style during one walk.

 

I hope this helps, too.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2020 Jul 14, 2020

Copy link to clipboard

Copied

LATEST

Thank you!! I probably should have figured out the hand movement part, but I don't think I ever would have gotten the Paramater recording with the "..." button without your help.  Much appreciated!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2020 Jul 14, 2020

Copy link to clipboard

Copied

   .

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines