Body Disappears When I Add Walk Behavior

Engaged ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

First, happy Thanksgiving. I'm sitting around waiting on the turkey and trying to make my puppet walk. I've successfully done it before, but, having installed the latest Ch update (2019, v2), I decided to start over following Okay Samurai's new walking tutorial. I successfully did this the other day on a less complicated puppet. Today though, I re-imported my much more elaborate puppet from Ps, added the walking behavior to the top level, applied and mapped handles to the limbs and went to record. AND MY BODY DISAPPEARED!!! It's really terrifying. My head bobs up and down as if walking, but there's no body. If I remove the walk property, my body returns, but, of course, he just stands there.

I'll happily provide whatever information or photos anyone would like. I am certain this is something simple and basic.

Martin

Screen Shot 2018-11-22 at 10.29.41 AM.png

Views

1.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Nov 22, 2018 Nov 22, 2018

I got the puppet. To make one step forward I suggest the following, click on Martin/Frontal/head frontal and look over in the tags area. You will see "Frontal" has been tagged on this layer as well as "head".

Turn off "Frontal" on this level - I think that is getting it confused. (You might want to rename the layer as well otherwise it will keep coming back if you edit the artwork file - don't include "Frontal" in the name anywhere)  You want Frontal on the immediate children of Martin. You also

...

Likes

Translate

Translate
LEGEND ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

Is the frontal layer visible by default? I think for walk that is required. Left/right profiles take over when required, but frontal must be the default visible layer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

Yeah all three poses are visible.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

I would check the views and handles of the walk behavior... oh, I notice you have Body Right Profile etc - you might want to check what is tagged - there might be multiple profile levels tagged getting it confused. E.g. it might have bound to “Head Right Profile” etc and ignoring “Body Right Profile” because it can only control one thing - so it hid the body layer. So you might need to remove some extra tags on Head Frontal, Body Frontal etc under Frontal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

alank99101739  wrote

I would check the views and handles of the walk behavior...

I'm not sure what you mean. The walk behavior (per the OkaySamurai tutorial) is tagged to the top level. I then assigned handles to each joint in the right and left profiles.

alank99101739  wrote

…there might be multiple profile levels tagged getting it confused. E.g. it might have bound to “Head Right Profile” etc and ignoring “Body Right Profile” because it can only control one thing - so it hid the body layer. So you might need to remove some extra tags on Head Frontal, Body Frontal etc under Frontal.

That's the way I've done it in the past so it can walk left and right. You'll see in the image below, I've got exactly two tags for each walk handle, one for right profile and one for left.

Screen Shot 2018-11-22 at 4.32.22 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

That part looks good.

But notice how "Views" says 23? It thinks your puppet has 23 views (!!). I am wondering if the Walk behavior is picking the wrong layer at times (like "Head Left Profile") and so it hides the sibilings (the "Body Left Profile"). That may be solved by removing the "Left Profile" tags that I bet CH has auto-added for your Head Left Profile and Body Left Profile layers. Something like that.

(Or share the puppet via a direct message if you want another set of eyes.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

alank99101739  wrote

…notice how "Views" says 23? It thinks your puppet has 23 views (!!).

Alan,

I've never even noticed—or read about—Views. Let me play with that and see if I can figure anything out. I completely appreciate your help, but before I ask you to fiddle, I want to see what I can do. You know, feed me a fish and I eat for a day…

Martin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

Why do you think I answer questions in the forums! 😉  I have learnt a lot doing so! So go for it!

It boils down to "why does CH hide things at times". The answer is swap sets (not relevant) and profiles (which you have). Hence my suspicion is it is hiding the body because it is a sibling of something that the profile code is turning on (which hides all siblings). Something like that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

OK, I took a swing and I don't think I really understand how to reduce which layer is being viewed in Walk without removing actual features. And even then I'm not clear what I'm looking for. Should there only be two views in the walk behavior? If you're game, I might send you the puppet. But I really do aspire to understand what's wrong and not merely get you to fix my problems.

Martin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

I got the puppet. To make one step forward I suggest the following, click on Martin/Frontal/head frontal and look over in the tags area. You will see "Frontal" has been tagged on this layer as well as "head".

Turn off "Frontal" on this level - I think that is getting it confused. (You might want to rename the layer as well otherwise it will keep coming back if you edit the artwork file - don't include "Frontal" in the name anywhere)  You want Frontal on the immediate children of Martin. You also want them on head turner profiles. You don't want them on the layer inbetween as well.

Then repeat for Martin/Frontal/Body Frontal, Martin/Left Profile/Head Left Profile, Martin/Left Profile/Body Left Profile, Martin/Right Profile/Head Right Profile, and of course Martin/Right Profile/Body Right Profile.  These extra tags were getting it confused.

I also hid Martin/Left Profile and Martin/Right Profile by default.

I will let you discover the next little issues you have! >:-)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

alank99101739  wrote

…click on Martin/Frontal/head frontal and look over in the tags area. You will see "Frontal" has been tagged on this layer as well as "head".

Turn off "Frontal" on this level - I think that is getting it confused.

OK, that makes sense and I would have never thought to look for that. Done.

alank99101739  wrote

You might want to rename the layer as well otherwise it will keep coming back if you edit the artwork file - don't include "Frontal" in the name anywhere

OK, done. Now my folder structure looks like below. Is this what you're saying?

Screen Shot 2018-11-22 at 7.41.57 PM.png

alank99101739  wrote

Then repeat for Martin/Frontal/Body Frontal, Martin/Left Profile/Head Left Profile, Martin/Left Profile/Body Left Profile, Martin/Right Profile/Head Right Profile, and of course Martin/Right Profile/Body Right Profile.  These extra tags were getting it confused.

I also hid Martin/Left Profile and Martin/Right Profile by default.

I will let you discover the next little issues you have! >:-)

Took me a while to figure it out. Now I just need to figure out how to improve my posture.

Thanks Alan,

Martin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 08, 2020 Aug 08, 2020

Copy link to clipboard

Copied

LATEST

This just fixed my puppet too!!! Thank you @alank. I have spent HOURS on this. definitely going to check with these forums before going down the rabbit hole alone.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

Yep, looks good. I know a good chiropractor if you need help with posture...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines