Can't get Limb IK to work on elbows

New Here ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

I've followed a couple youtube tutorials including the Limb IK tutorial and I've tagged each limb with the shoulder, elbow and wrist tags but I can't seem to get it to work for my puppet. 

TOPICS
Bugs

Views

193

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

I think the problem is the shoulder tag must go on the body that the arm is attached to, not the independent arm. The elbow and wrist go in the arm. (It is a common source of confusion)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

I've attached the shoulders to the body however the arms are still stretching and not flipping on an elbow bend.Screen Shot 2021-01-08 at 3.24.14 PM.pngScreen Shot 2021-01-08 at 3.24.26 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

Hmmm. Another screenshot please. In the properties panel shoudl be the Limb IK behavior you added. At the bottom there is "pin', views, and handles. Could you expand the handles section and include a screenshot? In particular, expand one of the shoulders. This shows the tags the behavior bound to. Want to make sure they are all 1 and it found the right one (when you expand it should show the path to the layer - we can check it found the should tag on the body and the elbow and wrist on the arm)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

It appears to link correctly when rigging.Screen Shot 2021-01-08 at 10.49.29 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 09, 2021 Jan 09, 2021

Copy link to clipboard

Copied

Well... (scratches head)... i have a suggestion and an offer unless someone else replies who can see what is wrong.

 

The suggestion is to find an adobe puppet with the limb behavior and see if it's working. If so, compare the properties and see if you can spot a difference.

 

The offer is if you still cannot spot it, feel free to export the puppet (using export puppet in menu) and load it into google drive or similar and i can try and fiddle too. I have not used it recently and cannot see anything that looks wrong. (I am wondering why it shows root and Frontal, but everything else is as expected). Sometimes there is a stray tag somewhere, but the bindings you have shown seem fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 09, 2021 Jan 09, 2021

Copy link to clipboard

Copied

You could try adding a neck tag on the body - i did not think it was needed, but it lists that handle with a count of zero. I am just making guesses now though.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2021 Jan 10, 2021

Copy link to clipboard

Copied

I've tried all suggestions. Here's a link to the puppet:

https://drive.google.com/file/d/11IjQtdoCs1h_y9JzHGZAG9c1r4K0cR6K/view?usp=sharing

I'm still very new to both character animator and Illustrator so maybe there's something pretty obvious I'm missing? I've tried to follow the following tutorials pretty closely which is why the head is independent: https://youtu.be/p05NNzb0lzo https://youtu.be/e85HGSAS80g 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 10, 2021 Jan 10, 2021

Copy link to clipboard

Copied

LATEST

D'oh! Yes, it was simple. I should have asked for one more screenshot!

alank99101739_0-1610321346199.png

(Ignore the comment about the eyes - when debugging someone's puppet I start be deleting as much as possible that seems irrelevant to reduce distractions.)

Basically, delete the "draggable" handle from the hands and add the "Draggable" tag to the wrist handles. Then it works!

alank99101739_1-1610321495247.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines