Can't get my puppet's head to tilt

New Here ,
Apr 07, 2018 Apr 07, 2018

Copy link to clipboard

Copied

Hi all,
I've been at this all day and I'm at my wits' end. It has been some months since I have used Character Animator and my old puppet, so I decided to start from scratch. I wanted to update some details in the Illustrator file (hands, eyebrows, cosmetic changes.) I've re-rigged the puppet and finally got everything working. Except, I cannot get the head to tilt. I've downloaded Chloe and Seth to examine how they are rigged. I'm stumped

Also, (not sure if it is related) the mesh and mesh outline do not outline the head or body. Instead they extend all the way out to the bounding box. I could really use some help solving this mystery. Thank you!

Dropbox - MOE_the_Knowbot_2018.puppet

Views

790

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 08, 2018 Apr 08, 2018

Copy link to clipboard

Copied

Nice artwork!

I think the problem is you have the "head" layer as NOT an independent group, and the children "frontal", "left profile" etc as independent groups. The "head" tag (used by the face tracking" is therefore associated with the main body, not the different profiles. The main body then moves with the head, but the actual head profiles are independent, so are not affected. I removed the "head" tag manually from the "head" layer, then added the "head" tag to each of "frontal", "left profile", "left quartile" etc and it started working.

Not sure if this is the correct approach - I have not used head turners yet - but it seemed to work. (I don't know if a better solution is to make the "head" layer independent instead for example).

You may also want to reduce the "head position strength" to keep the head closer to the rest of the body (it floats away a bit when I was playing with it).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 08, 2018 Apr 08, 2018

Copy link to clipboard

Copied

Oh, and regarding the mesh, there is a property "Mesh Shape" which you can change from "Auto" to "Contour" to get it shaped correctly. Auto struggles when there are multiple unconnected parts in a layer. I don't know the exact rules. But try changing the property to "Contour" and see if that fixes the problem for you. I suspect less of a problem with your puppet since the head is pretty rectangular and things like eye movements and eyebrows etc don't warp the head.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 11, 2018 Apr 11, 2018

Copy link to clipboard

Copied

This fixed the Mesh Shape problem. Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 11, 2018 Apr 11, 2018

Copy link to clipboard

Copied

LATEST

Ok. I tried this and didn't get the exact results I was looking for. It was better. And most importantly you made me want to continue to figure out what was going on. I ended up reverting back to many of my original settings. Head is tagged "head" and not independent. The head turns (frontal, left profile, etc.) are independent and *not* tagged "head". Then I made sure the head and body were "attached to" "MOE" (the top level puppet layer) and that the head turns were "attached to" "head". Before these were all set to "auto" Also, I changed the "attach style" of the head turns from "weld" to "free". Now I'm getting the results I wanted. Not sure if what I changed fixed it or if it was just restarting the program. Regardless, Thank you so much for taking a look at this and helping me to fix the problem.

And thank you for the compliment on the artwork!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 08, 2018 Apr 08, 2018

Copy link to clipboard

Copied

I'm not an expert but a beginner. So here's a suggestion in that category. Make sure you don't have little tiny parts left around the character. It will throw everything off. I always do a sweep around the "blank" spaces in Illustrator when I'm importing assets to CA.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 10, 2018 Apr 10, 2018

Copy link to clipboard

Copied

In the "body" group you have a hidden "Lines" layer that's doesn't overlap anything else, so the default Mesh Shape of Auto will switch to a rectangular mesh to encompass all of the pieces. (It looks at the hidden layer and tries to include it in the mesh in case you might trigger it on.)

As for the head tilt, after removing the Lines layer, try increasing Head Tilt Strength.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 11, 2018 Apr 11, 2018

Copy link to clipboard

Copied

Thank you! I missed the extraneous layer. I've deleted it

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines