Character Animator crashes on launch (mac)

New Here ,
Aug 22, 2020 Aug 22, 2020

Copy link to clipboard

Copied

CA crashes just after launching on the project page if not sooner, but I'm not getting any error msgs. All other programs in the CC suite work great. Are there crash logs I can check to see what is causing the problem? I assume its a conflict with something on the machine. I have a project coming up and really need to get this running. Any help would be appreciated!

I have:

-Uninstalled, restarted, and reinstalled with all other programs shut down including anything that would access the camera or have malware/firewall protection on.

-Deleted preferences
-Have tried downgrading all the way to version 3 and up to the Beta version

My Specs 
Mac Pro (Late 2013) Running High Sierra (10.13.6)

3 GHz 8-Core Intel Xeon E5

64 GB 1866 MHz DDR3

AMD FirePro D700 6144 MB

TOPICS
Crash

Views

566

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 22, 2020 Aug 22, 2020

Copy link to clipboard

Copied

Sorry it's crashing on your machine. Has it always done this?

Do you use any Wacom tablet software? If so, can you see if updating to newer Wacom tablet software will help? There were issues in earlier versions with older Wacom software.

 

A crash report (.crash) file should appear in your user Library/Logs/DiagnosticReports/ folder (in a Finder window, hold down Option while opening the Go menu to access the user Library folder).. Look for a file with Character Animator or Character Animator (Beta) in the name, and ending with a .crash file name extension, and matching the date/time that you recall it crashing. Seeing the contents of the file might help us diagnose what's causing the issue.

 

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 23, 2020 Aug 23, 2020

Copy link to clipboard

Copied

Hi Jeff, thanks for the response.

I do not use a Wacom. 

I am not finding any .crash reports but I do have 4 log files generated at the time of the crash. What's the best way to get them to you?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 24, 2020 Aug 24, 2020

Copy link to clipboard

Copied

Are these Character Animator log files, or other system logs? If you want to zip up the files and send me a direct message with a shared link to them (e.g., via Dropbox, Google Drive, etc.), I can take a look. Also, if you can let me know the date/time (and time zone), I can see if I can correlate that with any submitted crash reports on our side. Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 25, 2020 Aug 25, 2020

Copy link to clipboard

Copied

Try holding down the option key while launching to force Ch to open a new project.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 28, 2020 Aug 28, 2020

Copy link to clipboard

Copied

Unfortunately, holding option or shift on launch did not work . I get to the project page. The blue bar at the bottom says "Creating Character animator Project #" and then as soon as I move the mouse, it crashes. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

Something similar happened to me. When I opened CA for the first time after installation my Macbook Pro ( macOS Mojave, 2.3GHz Intel Core i5, 8GB 2133 MHz LPDDR3, Intel Iris plus Graphics 655 1536 MB) shut down. I do have a crash log too. The path : /Applications/Utilities/ Adobe Application Manager/*/UpdaterStartupUtility. Did it crash because of CA?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

Are you on macOS 10.14.0? There was a known compatibility issue with 10.14.0 that was addressed in 10.14.1 and later.

 

If you are using macOS 10.14.1 or later, what version of Character Animator do you have installed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 23, 2021 Apr 23, 2021

Copy link to clipboard

Copied

I'm on version 10.14.1 and have the latest version of CA installed

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 23, 2021 Apr 23, 2021

Copy link to clipboard

Copied

The crash log path seems to point to something outside of Character Animator.
It sounds like the crash wa only on the first launch after installation?
Maybe the Creative Cloud desktop app was trying to search for updated versions around the same time.

Do you recall getting a window titled Adobe Crash Reporter (not Apple Crash Report) when or soon after the crash occurred? If so, were you able to submit a crash report at the time?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

LATEST

No I don't remember getting any crash report window my Mac just shutdown. But It works now thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 28, 2020 Aug 28, 2020

Copy link to clipboard

Copied

These types of things are usually hardware related. I've got a couple of very similar machines, so I'm hoping it's an external device or drivers for a disconnected device. 

Have you tried launching with nothing connected to the machine but the keyboard and mouse?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 28, 2020 Aug 28, 2020

Copy link to clipboard

Copied

Also, any chance you were looking in the system library instead of the User library when you were looking for those crashlogs? Here's my local location showing what these look like. 

Screen Shot 2020-08-28 at 3.50.44 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 30, 2020 Aug 30, 2020

Copy link to clipboard

Copied

-Disconnected everything from the machine but mouse and keyboard, still crashed.

-Confirmed that all the logs I found are from the correct location as shown above. Still no crash logs.

But I did find this in the system log at the time of launch. Not sure if it's useful.

 

Screen Shot 2020-08-30 at 12.29.22 PM.png

 

Aug 30 13:15:12 MP604 Character Animator[1950]: Character Animator(1950,0x7fffac001380) malloc: *** error for object 0x610000180750: Invalid pointer dequeued from free list
*** set a breakpoint in malloc_error_break to debug

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 30, 2020 Aug 30, 2020

Copy link to clipboard

Copied

The Adobe folks know best, but I assume you tried the simple thing like removing and then reinstalling the software?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2020 Sep 01, 2020

Copy link to clipboard

Copied

Yep, even tried going back several versions and tried the beta version as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 01, 2020 Sep 01, 2020

Copy link to clipboard

Copied

If you create a new user account on the machine and run from there, does it still crash?

Has Ch ever worked properly on this machine before? If so, can you think of anything that changed just before it started crashing?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines