Character Animator Project Couldn't Be Saved and now Corrupted

Explorer ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

I was adding a behavior to a puppet and was informed that another application had modified the project to close and open again.

When I reopened the file, it says that there is an repo.noindex can't be opened.  I copied the whole project out of my creative cloud files folder, and am trying to open from the desktop.

 

As far as I can see the repo.noindex is there. is it possible there's a lock file? or a permissions thing?

 

Is there ANYTHING I can do to save this project?  (a lot of work has gone in to this - and this is the SECOND time I've had to re-do the work due to a similar, or identical, but that corrupted my project before)

 

 

2020-09-09_12h54_47.jpg

 

 

 

 

 

 

 

2020-09-09_12h57_28.jpg

 

FWIW - poking around I found a "CONFLICTED" version of a master in refs.

 

master

and 

master (Conflicted copy from <########> on 2020-09-09)

* <######> is my redacted computer name.

 

I tried removing the confliced one, I tried removing the "master" and renaming the conflicted one and still the same result.

 

Oh I also zipped the project up before trying to open again since Character Animator geniously (sarcasm) immediately saves everything it does as the "new" version so once you open a corrupted file it's "poof" - though I do see a structure in the database that looks similar to git, so I'm hoping that somehow some way I might be able to get some help recovering the file.

 

I definitely believe it's related to Creative Cloud Sync - which apparently I'm a fool for using as a working folder!  I'm going to have to just make a "push" script to robocopy my wip from my HDD to Creative Cloud folder... but more importantly, I'll have to be sure to exit from Ch and zip the project before copying it.  I would say it's my bad for using the beta character animator but... this happened previously with the standard release.  It's Creative Cloud that's the poison. Not to mention the horrific behavior of WIPING OUT the file if Ch has trouble opening it. if a glitch prevents Ch from opening properly it saves over the existing project with an empty project. sheesh.

 

PLEASE HELP! if there's any way to recover the project from the database.

 

 

 

 

TOPICS
Bugs , Crash

Views

56

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation