• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Character Animator Puppet Importing Frenzy

New Here ,
Oct 02, 2018 Oct 02, 2018

Copy link to clipboard

Copied

Hi,

My Character Animator is giving problems when I make changes to my puppet in Illustrator and save it. Instead of applying the changes to the current puppet it imports a new puppet and just ads a number sequence to the name. For example Charlie would be imported as Charlie 2, Charlie 3 and so it continues..

The problem doesn't stop there, even if I don't save anything out of Illustrator and just make a change in Character Animator a new version of the puppet is imported.

Can anyone please help me with this? Any enlightenment would be greatly appreciated!

Views

194

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 02, 2018 Oct 02, 2018

Copy link to clipboard

Copied

How do you start up the editor and load changes? have you tried control-E to edit in the rig panel in CH then just click save In illustrator? Does that create a new puppet? I would suggest clicking the refresh button at bottom right of scene window (two arrows in circle) to flush CH caches. Very strange!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 02, 2018 Oct 02, 2018

Copy link to clipboard

Copied

Thanks for the response, much appreciated!

Everything was working fine up until today, I've been busy with a project with 3 characters each with 3 angles, frontal, quarter and side profile. I usually have Illustrator and Character Animator open at the same time and the when I made changes in Illustrator I'd press CTRL+S to save, go back to Character Animator and the changes would sync but it doesn't register like that any more. The duplicate puppets started when saving out of Illustrator but now it happens even if I just click on the puppet in Character Animator or randomly when I'm busy with another puppet in Animator. It only happens to one of the puppets though. The saving problems is with all the puppets, I've tried the refresh button but it's like the program doesn't respond.

What also started happening when I tried closing Animator to see if that fixes the problem, I opened it up again and all of my scenes are blank, the timeline still shows the recorded content but the puppet doesn't show. Only when and after I save the project does the puppet reappear.

I realize that what I'm saying might not make sense and that it'll be difficult to assist me so I concluded that it might be better to just export the puppets, save the projects and reinstall the program because it use to work fine.

Just one last question on the side, do you know if Adobe's programs function better with the Mac OS the Windows? I have the whole Adobe suit and have experienced a number of explanatory problems with not only Character Animator.

Once again, I do appreciate your response and willingness to help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 02, 2018 Oct 02, 2018

Copy link to clipboard

Copied

That is strange. Sometimes magical incantations like “oh great and wonderful DanTull​ - is this of any interest to you?” can help. He likes collecting test cases.  But that sounds very strange.

Maybe keep the old project, but export the puppets and see if a new project works better... I have not heard of the problem you describe before.

i only use Windows - no Mac experience. I get crashes or lockups periodically. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 02, 2018 Oct 02, 2018

Copy link to clipboard

Copied

LATEST

Whoa. That does sound like a good bug. Thanks for pointing this one out, Alan. (not sure about great and wonderful, but I do like a good bug hunt, especially if it ends with the bug being fixed)

I feel like we've cornered a bug like this before, but it does sound like an interesting one worth figuring out. Probably the best way is if I can get a copy of the project and the illustrator file that's causing the issue. If it seems elusive, a screencapture might be good to grab as well in case there are clues that might help me elicit the behavior by inspection.

Thanks -- DT

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines