Character Animator Puppet not updating from Photoshop design

New Here ,
Mar 20, 2022 Mar 20, 2022

Copy link to clipboard

Copied

Screen Shot 2022-03-20 at 9.23.18 PM.pngScreen Shot 2022-03-20 at 9.26.17 PM.pngHi, I'm trying to make my character have all black skin, but on character animator the skin colors don't seem to be updating. Thanks in advance for your help!

TOPICS
Bugs , How to

Views

71

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

By default, CH won't update until the focus is returned to the program. It won't automatically update while you're saving in Photoshop. Even so, subtle changes require a little more of a "push" to get CH to realize that an update is needed. Turn off a layer or move a part and save to see if that gets the attention of CH (before, of course, moving them back). 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

You might be running into the problem of PS saving in the background and not being finished before switching to Ch. Either wait for the save to be finished before switching, or turn off PS’s Preferences > File Handling > Save in Background.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

I tried deleting the puppet file off character animator and reuploading the photoshop file. It still shows up like that with weird color mismatches even though when i view on photoshop (and on the file thumbail in Finder), it shows up as all one shade of black.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

LATEST

Updating since i found the solution and am always annoyed when ppl don't update if their question got answered:


For some reason, I guess Photoshop has a bug that doesn't let you apply color overlays to entire folders at once. So I had to clear all layer styles, then apply it the color overlay layer by layer.

 

This also helped:

 

https://community.adobe.com/t5/character-animator-discussions/issue-with-color-overlay-from-photosho...

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines