Character Animator Puppet Walk Behavior Not Working Correctly

New Here ,
Mar 28, 2018 Mar 28, 2018

Copy link to clipboard

Copied

Hi CA Think Tank!

I am having an issue getting this puppet to walk correctly. She is rigged exactly like another character I have, who walks perfectly. However, she only wants to walk in one direction. She has 3 profiles, normal, right, and left. Any help would be amazing! Here are the links to the puppet and .ai file. Thanks for any help in advance!!!

Dropbox - Woman_Puppet.ai

Dropbox - Woman_Puppet.puppet

Views

766

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Guru , Mar 30, 2018 Mar 30, 2018
Sorry about that.Try this link B_Woman_Puppet.puppet - Google Drive In this one I re-tagged the legs on the right profile. It seems to work, but I don't know why. I just tried different things until I got to this one. It took a while.

Likes

Translate

Translate
Guru ,
Mar 29, 2018 Mar 29, 2018

Copy link to clipboard

Copied

I tried your puppet and it seems to be walking okay each way. I did move the left arm to behind the body when walking to the right, but that had no effect on the walk behavior. Can you provide more info on what you are seeing that doesn't look good?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2018 Mar 29, 2018

Copy link to clipboard

Copied

She only walks to the left, when I click the left arrow. However, when I click the right arrow, nothing happens....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Mar 29, 2018 Mar 29, 2018

Copy link to clipboard

Copied

That's strange. I downloaded your *.puppet, brought it into Character Animator, and put it in a new scene. Left and right arrows each work fine. I can make a screen cap if you want to see it.

Can't think of anything else to do. Here is a link to the *.puppet I made from yours. Besides moving the left arm, I deleted two items from the trigger panel that seemed not to be working. I don't think these changes have anything to do with the walking

Edit: see link below

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2018 Mar 29, 2018

Copy link to clipboard

Copied

I can't open, says a need Version 1.5? I have version 1.1.1, but it doesn't seem as if there are any updates?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Mar 30, 2018 Mar 30, 2018

Copy link to clipboard

Copied

Sorry about that.

Try this link B_Woman_Puppet.puppet - Google Drive

In this one I re-tagged the legs on the right profile. It seems to work, but I don't know why. I just tried different things until I got to this one. It took a while.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2018 Mar 30, 2018

Copy link to clipboard

Copied

It works! By re-tagging you mean the sticks and anchor points? So weird that it wasn't working. Any ideas why it wasn't?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Mar 30, 2018 Mar 30, 2018

Copy link to clipboard

Copied

LATEST

By re-tagging I mean that on the right leg I changed the knee, ankle, heel and toe tags from "right" to "left." See the screen cap. The sticks are not tagged. Then I did the opposite on the left leg. This was only on the right profile legs.

I do not know why the initial tagging didn't work, or why this did; that needs someone who knows more about the underlying coding than I do.

ReTags.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines