Compute lip-sync did not work

Community Beginner ,
Jun 23, 2017 Jun 23, 2017

Copy link to clipboard

Copied

I finally got my audio recorded (a duet song) and did a little test today. Oddly, the only audio track that is working with compute lip-sync includes the background music and the puppet mouths to the instrumentals...an effect I do not want. I saved the audio into separate files for each character without the instrumentals but for some reason (even though they are all mp3s) the individual audio tracks aren't working. Is there an amount of time into the audio track that character animator expects to receive input in order for Compute Lip-sync to function properly? I have a large block of dead air before the voices chime in. Just trying to figure out how to fix this issue. Does it expect a different file type?? Please advise. Thanks!!

Views

1.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 23, 2017 Jun 23, 2017

Copy link to clipboard

Copied

When you say it doesn't work, what happens exactly? Do you end up with a Viseme take, but no Visemes? Does it take time to process the audio?

Having a big silent part should be fine, but maybe you've found a bug related to that. If you're willing to share your audio file with us we can test it here...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 24, 2017 Jun 24, 2017

Copy link to clipboard

Copied

I get a Viseme take but no Viseme is created. I'm going to try some different formats just to see if it may be the files. I'll let you know. If other file formats have the same result..I'll send you the audio file. BTW-How do I send you the file??

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 25, 2017 Jun 25, 2017

Copy link to clipboard

Copied

Perhaps the audio level in the file is too low? To send me the file, you can use a creative cloud asset link, dropbox link, or any other service that lets you upload files and then share a link. Post here for public, or direct-message me to keep it private.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2017 Jun 25, 2017

Copy link to clipboard

Copied

Today I tested an mp3, a .wav and a .aif. We made sure to give the test audios the same amount of dead air as the file I was testing earlier. The .aif is the only one that actually produced visemes.

Looks like a bug.

I messaged the files to you. Did you receive them??

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 25, 2017 Jun 25, 2017

Copy link to clipboard

Copied

I got a message (not my colleague), but I didn't see any links in them. Did it include shared links via Dropbox, Google Drive, etc.? I don't think direct attachments will work.

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 30, 2017 Jun 30, 2017

Copy link to clipboard

Copied

I tried messaging the files but haven't heard back whether you received the link to the audio files. I tried to message again today but for some reason the message link isn't working. I have the audio files ready when you want them. Please let me know how to get them to you.

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 30, 2017 Jun 30, 2017

Copy link to clipboard

Copied

Did you send them to my colleage, David, who was originally asking for them? I only saw one attempt to me, and didn't see any links.

If you have the file in Dropbox, Google Drive, or similar, there should be a way to share a link to it. That would create a URL that you can then paste into a message here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 30, 2017 Jun 30, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 30, 2017 Jun 30, 2017

Copy link to clipboard

Copied

That link worked to download the audio files, but it seems to work fine for me. Can you list your exact steps, version of Ch, and OS version? Thanks!

Note that Adobe is shut down for the holiday over the next week, so our responses will be slower than usual.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 30, 2017 Jun 30, 2017

Copy link to clipboard

Copied

I'm on a Mac using Sierra version 10.12.5

Character Animator Beta (modified May 4, 2017)

I simply imported the audio file, added it to the timeline, selected the character and the audio and had the software create the Viseme by going to Timeline and compute lip sync. The only file that works for me is the .aif.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 02, 2017 Jul 02, 2017

Copy link to clipboard

Copied

Strange, all 3 files work fine for me. I'm also on 10.12.5. What version number shows in the menu bar (the modification date is from when you installed, not the specific version)? For the latest version as of today, it should say Beta 6 right next to the Help menu.

If you're already on Beta 6, the next step, if you're willing, is to do a screen recording showing the steps that lead to the bug. That may give us clues as to the cause. You can use QuickTime player's File > New Screen Recording to do this, and share the resulting file. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

Hello,

I was wondering if you found out the problem cause I encountered exactly the same problem he described above but even aif files are not working for me. I tried different audio file extensions (mp3, wav, aif) and nothing worked out. Whatever is the audio extension I am always getting a single visemes file but not separated ones. The lip sync is working but the problem that in this case I can't do any corrections as the visemes are not there... May you please advice on this issue?

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

Could you supply a screenshot of your timeline and tracks? i Don’t quite understand what files you have (a separate file per voice?) and what puppets you want them to lip sync too. 

Please note, if a longish track, you may need to zoom in on the timeline for the vizenes to be visible. try zooming to 20 seconds across the screen (zoom control is in bottom right of timeline panel - the little mountain bug and small)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

You helped me! I feel so stupid. It was actually the zoom as you indicated. When I zoomed everything showed up! Thanks a lot

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

Not stupid at all. I spent a time longer than I will admit in public trying to work out what was going wrong recently - only to find out zoom was that problem. I would suggest that CH should draw all vizemes at least one pixel wide on the timeline to stop them from being invisible.

The only reason I thought of it was that it was also a song reported a week or two ago that had the problem. It seems a recurring pattern - songs end up with longer scenes (a few minutes) in order to sync the music just right, causing the zoom factor. On my screen, it was around 2 minutes zoom size that things would start to disappear.

Glad you got it sorted!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

LATEST

Thank you

In my case the audio is just a 20 seconds dialogue but the zoom obviously was very low to see them. I've spent 4 days trying to understand why I have that and I finally got it thanks to you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines