Couldn't find required item at project path/ProjectItems/Character

New Here ,
Nov 22, 2017 Nov 22, 2017

Copy link to clipboard

Copied

OK, so I created my puppet and rigged it and it all works well but I need to save it out as a separate puppet to usein a new project. When I did this and dropped the puppet into a new scene, did some recording I got this error message popping up:

"couldn't find required item at project path/ProjectItems/Character"

So I deleted the project and did a 'save as' from my original project and still got the same error message. But everything seemed to work fine except I couldn't see any controls available in the controls panel nor could I generate any or drag thing into the panel.

Undetered I set about animating my character and everything seemed to be work until I opened the project up this morning, I got the same error message on startup and although the scene file contained all the recordings the character had dissapeared although I could still open the puppet file within the project. Fortunately I opened another test file which contained the same character which I then closed, I then opened my project with the error message and the error message dissapeared and the puppet was back in the scene again.

I am wondering whether this has anything to do with the fact that the linked PSD file for the character is not in the 'Gathered Media' folder but somewhere else on my hard drive and Ch is having a game trying to find it. The link is working when I update the character in PS.

I am still working on this project and occasionally get the same error message when I finish recording or updating the character in PS.

Is this just a bug? It seems that Ch is trying to find my character file all the time.

Views

953

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 22, 2017 Nov 22, 2017

Copy link to clipboard

Copied

Does relinking work?

Also, if the files are in a cloud-backed folder like Dropbox, try moving them locally instead - that sometimes helps too.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 22, 2017 Nov 22, 2017

Copy link to clipboard

Copied

Hmm. That 'couldn't find required item at project path' error (if I'm reading your description right) is actually referring to a path inside the project structure (ProjectItems is the virtual "root" folder inside the project itself whose contents are shown in the Project panel). It sounds like your project has actually been damaged or left in a bad state. If you could zip up a project in this state and send it to me, I'd like to take a look and try to diagnose what has gone wrong.

We fixed a bug like that in 1.1 which would occur when performing a Save As operation on a project where the project's name (in the filesystem) matched the name of a top level item in the project panel inside Character Animator.

Anyway, the history in the project might give me enough info to figure out what has gone wrong if you'd be willing to share it.

Thanks -- Dan Tull

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2017 Nov 23, 2017

Copy link to clipboard

Copied

Hi Dan

That sounds really useful but where do I send the file to? I was going to zip it up and e-mail it or WeTransfer it so I would need an e-mail address (I am new to these forums so only just learning the ropes).

Also FYI the character used in the project is not in the 'Gathered Media' folder but an external folder. I will include it with the project file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 17, 2022 Feb 17, 2022

Copy link to clipboard

Copied

Hi, Dan!

 

I'm getting a similar error - in the most recent updated version. Could you let me know if you've found a fix or if I need to send the file in? 

Thanks!

- Harlie

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 17, 2022 Feb 17, 2022

Copy link to clipboard

Copied

LATEST
 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines