Framerate setting of stage compromises Physics!!

Explorer ,
Aug 01, 2021 Aug 01, 2021

Copy link to clipboard

Copied

Hi all, I have upgraded to 4.4 but this problem remains bugging me since ever.

 

I have a puppet with a floppy tentacle, that uses Dangle to bounce a bit while moving. The bounce looks nice in the editor, but when rendered, it gets out of control.

I would like to use native 60fps, so i set the stage to 60 frames per sec.

The tentacle now is quite rigid, like stiff frozen jelly.

When setting the stage to 30, the rendered result is much more alike the editor preview!

Setting the stage to 15 fps results in the tentacle to become weird overstretching rubber.

 

Same problem with wind. it looks unnatural fast and stiff at 60fps stage setting, almost acceptablle at 30 and absurdly distorted at 15!!

 

Same with blink! a blink lasts 1 frame. and of course... it is horrific at 60, kind of ok at 30 and sedated at 15. 

 

i guess 24 would be just perfect, but... no.

 

Is there a switch to tell the physics simulation to behave correct in 60fps? any config file, i could edit with an text editor? 

 

Will it be solved in a future update? and how will you keep compatibility for old scenes?

 

Thank you so much for listening to my rant and please help! 🙂

 

Best

 

Marius

TOPICS
Bugs , Feature requests , Puppet movement

Views

57

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

Ideally Ch would be frame-rate-agnostic, and give you the same overall result when you adjust the scene frame rate. That was our original goal, but we had to give that up to be practical in terms of performance (for Physics) and to ensure that when you use hand-drawn cycles, it doesn't skip any of the frames.

 

As a result, we recommend setting your desired scene frame rate early on, and then adjusting things like Physics > Dangle > Stiffness, and Cycle Layers > Advance Every N Frames parameters until you get the look you want. If you want to change the frame rate later, drop the scene into an After Effects composition set to your desired frame rate (you'll need to turn on Frame Blending if you increase the rate), and render from there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

Hi and thank you for your answer.

Hmm, now I have an idea, how this problem came into the world. The problem is, that, if you use Stage settings different than 25 fps, all effects that do have a fall-off time will look unnaturally. Wind and dangle is not adjustable to match the scene, as the fall-off on a 60fps stage will always look like more than 2 times speeded up footage. 

Question: the Viewport seems to be unaffected, even when the realtime-display reaches 60 fps- the physics do look fine. When rendering the final result the physics are baked wrongly. Is there a config-file/possibility to force physics to be based on 60 frames? 

Using nested scenes in After effect do not seem feasible as the frames will be tweened from the lower frame rate using interpolation. 

 

Thank you for your efford

 

Best Regards

 

Marius 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

LATEST

>Using nested scenes in After effect do not seem feasible as the frames will be tweened from the lower frame rate using interpolation. 

 

True, but when using Pixel Motion option it might look good enough that you can't tell (will depend on the content).

 

Your request would be another way to implement it: add a parameter for simulation rate that would be independent of the display frame rate. When the former is not perfectly divisible by the latter, some interpolation would be needed which might make it jittery, but you could always pick a perfect multiple if you wanted. Or add it as an explicit multiplier.

 

If you'd like to request this, please post it on UserVoice: https://www.adobe.com/go/characteranimator-uservoice

 

Or if this matches what you want, you can vote for it: https://adobe-video.uservoice.com/forums/911317-character-animator/suggestions/43544157-blink-and-ph...

 

Oh, wait, that's probaby your request!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines