Frontal view not showing when stopped walking

New Here ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

Hi there!

I'm new to animator so sorry if this is dumb but I followed a tutorial and the thing he said to fix this didn't work.

So my character only shows up in the walk cycle when he's walking, not when I stop pressing the arrow key. The layer is turned on, which was the tutorial's fix for this. Not sure what I'm missing.

Screen Shot 2018-11-06 at 3.01.50 PM.png

Screen Shot 2018-11-06 at 3.03.55 PM.png

Screen Shot 2018-11-06 at 3.03.49 PM.png

I've also tried tagging the frontal one with left profile too per someone's answer on here before but that didn't work either.


Thanks for the help!

Views

396

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Nov 06, 2018 Nov 06, 2018
Try expanding the “Handles” section of the walk cycle. That should show you what the wall cycle has bound to. (Feel free to include a screenshot here.)My recollection from a tutorial was the “Frontal” tag is not used. It does not hurt, but its not used. (Hmmm, not sure if that changed in the latest release now there are quarter walk profiles.) What is important however is to make the frontal layer visible and hide the other profiles (turn off eyeball). When turning, it will hide all siblings exc...

Likes

Translate

Translate
LEGEND ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

Try expanding the “Handles” section of the walk cycle. That should show you what the wall cycle has bound to. (Feel free to include a screenshot here.)

My recollection from a tutorial was the “Frontal” tag is not used. It does not hurt, but its not used. (Hmmm, not sure if that changed in the latest release now there are quarter walk profiles.) What is important however is to make the frontal layer visible and hide the other profiles (turn off eyeball). When turning, it will hide all siblings except the direction its facing when walking left/right. It will just display the default settings when not walking (it does not hide the other profiles is my recollection - “Frontal” is not actually used.)

Sorry, not near a computer to confirm. That is my recollection.

That does not quite explain what you are seeing however - the screenshots showed lots of eyeballs on. But I was not sure if you were changing that during debugging.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

Oh, check the “Views” are too, just above “handles”. If you could expand them both and include a screenshot here that could help. I notice it says two views.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

Thanks for the quick response!

It only seems to identify both angles if I tag the front view with front and left. If I don't tag front at all, both views show up in walking and front is in the way obviously haha

Screen Shot 2018-11-06 at 3.51.07 PM.png

(with just the frontal tagged ^)

Screen Shot 2018-11-06 at 3.52.39 PM.png

^ that's with the front and left view tagged, it shows up, but then when I got to the walk cycle, it only shows the right profile.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

Do you have a head turner behavior added As well? It shares the same tags which can create confusion. If so, check it’s view area etc as well for unexpected things.

You should not put the left profile tag in frontal.

Note - you see some of the handles have count 1 and others 2? Strange! Eg left toe has 2 but left heel has 1. I would expand them as well And see what is going on.

if your puppet only has a right profile, that should be fine. i would tag frontal and right profile and leave rest off. Then check the toe etc and view sections to see if it makes sense or strange things going on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

I don't have any behaviors on it other than walk.

I think I didn't mark the feet as much for the frontal since it doesn't matter cuz it's not moving, but I added the missing tags.

When I only tag frontal and right view, only the right view comes up in the walk cycle under views which I think is the main issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

Reading back over this. My *recollection* was you should have

+Turkey

   +Frontal (no tags, visible)

   +Right Profile (“Right Profile” tag, HIDDEN)

That is, viewing the puppet without and keyboard keys etc should show the default puppet setup, which has the Frontal display and Right Profile hidden, because that is the default puppet setup.

If you don’t have a left profile, don’t tag anything with that tag. Don’t put it on the Frontal profile.

Under Views you should only see “Right Profile” (because you don’t have a left profile). You will not see “Frontal” because the walk behavior does not know “frontal” as a concept. It either triggers a profile and manipulates that, or it does nothing (just displays the puppet‘s default setup).

Under Handles you should only see a count of 1 max (because you only have 1 profile, “Right”).

So when you hit the “right Arrow” on the keyboard, it kicks in and displays the right profile, hiding the siblings of Right Profile (in this case, the only sibling is Frontal).

I would check the +Turkey layer for any stray tags. I would actually go through the whole puppet and check as well! ;-). Stray tags can confuse things. Expanding Views and Handles can help spot stray tags due to unexpected parts of the puppet showing up. I have not seen any in the screenshots you provided however.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

When you say hidden, you mean like turn the eyeball off? Because then it doesn't do anything when I walk, it just shows the front view. If I misunderstood, could you explain the hidden tag by chance?

I'm wondering where this 1 is coming from on the frontal group too. Maybe that's the issue? but I dont see anything as tagged when I click on it.

Screen Shot 2018-11-06 at 4.29.06 PM.png

Again thanks for your help and patience!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

Yes, the eyeball is for hiding. I expect to see “Right Profile” with the eyeball off and only the “Frontal” layer have it on.

For example, try removing the Walk behavior. You should see the frontal view of the puppet (no profile views) and it should basically behave correctly.

Then, once that works, add the Walk Behavor back on again. With no arrow keys pressed, it should behave exactly as before without the Walk behavior. When you press the right arrow key, it should show the “Right Profile” layer and hide its sibling layers (in this case, “Frontal”). The Walk Behavior does not understand the concept of “frontal” (is my understanding), so tagging with Frontal should have zero effect.

I cannot remember whether it is good, bad, or does not matter for idenependence of the Frontal and Right Profile layers to be honest. I don’t recall if they *should* be independent to avoid handles etc on layers getting mixed up. So my other comment about removing independence may or may not be correct!! (Undo is your friend.)

What are the numbers next to the layer names for? They indicate the number of handles added to that layer. You can put draggers on a layer for example. So they are not tags. BUT you can tag handles. That is how the walk behavior controls legs etc. That is why your leg layers have like an ”8” - there are lots of handles with all the tags for Left Toe etc. The walk behavior effectively does dragging for you, just like a dragger. But it computes the drags on your behalf, automating the Walk behavior for you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

Oh, and to clarify one point, if you look at the property panel X/Y values, you can only ever see the puppet defaults. There is no way to see the values in recordings that I know of. So the recordings, once made, cannot be inspected (which *is* annoying). You just have to remember what they were. That might have been your question - sorry for the longer explanation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

Still no dice, unfortunately. Something else I noticed is that for some reason when i select the frontal layer, a yellow line appears next to where the crowns would be on seemingly random layers, but when selecting the right side, they do not? I'm just looking for anything that might be a reason haha not sure if you know what this means.

Screen Shot 2018-11-06 at 5.07.21 PM.png

Screen Shot 2018-11-06 at 5.07.29 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

LATEST

That is because in the right profile you have marked the head and body both to be independent (have crowns). I mentioned that I think you have too many crowns in the frontal profile - I suggest removing the crown from the body layer at least.

One analogy is using each layer is like a sheet of paper. You can cut out all the bits of paper into shapes you want, then you stack all the layers of paper together.  If you remove the crown, its like gluing the bits of paper together. They won’t slide around any more. If you put the crown on, you can slides the bits of paper, unless you use pins to join them. E.g. the anchor point for an arm attaching to the body is like a pin. Weld is like putting glue on the joint (so the papers move less freely), hinge is like putting a free swinging joint.

The yellow markers are a hint showing which layers are all glued together and so will not move relative to each other. I call this a “dependent group of layers”. (Not sure if there is an official term.) So Body under +Frontal is “dependent” upon Frontal (they are glued together). If you click on Frontal, then the yellow outline in the puppet display area shows you the yellow outline of all the layers in that dependent group.

I note in that last screenshot you have not turned off the eyeball for “Right Profile” yet. You also have Head and body both independent as well. I suggest turn off the eyeball for Right Profile, then turn off the crown for Body. (In the artwork file, I also suggest removing the leading “+” character so later changes don’t turn the independence setting back on when you are not looking).

If still no luck, feel free to “Export Puppet” from the menus, upload to Google Drive/Dropbox/etc, and share a link (via direct message if you prefer). I can have a look when I am home After work tonight.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

It is probably irrelevant, but you could try taking the “crown” icons off the frontal and right profile layers as well. You only need them if the layer needs to be be independent. You can go too far with too many crowns, causing problems. E.g. your frontal “body” is also marked independent, but not the head - but the right profile has what I am more used to and has the body NOT marked as independent.

Tails and legs make sense being independent, so they can move. The head can make sense being independent, so it can pivot on the neck. The body to me rarely makes sense being independent. It is what everything else attaches to normally.

UPDATE: The above may have been slightly bogus. Having independence on layers also helps stop the contour of one profile affecting the contour of other profiles, so it probably is the right thing to have them marked independent sorry. My bad!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines