Image sequence trigger issue

Community Beginner ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

So I have a series of pngs I want to have load as a smoke effect. I imported the sequence and set parameters in the cycle layers behavior. I then set a trigger for image sequence by clicking the smoke layer and clicking the + in the trigger section, however the trigger text appears orange even with a unique keyboard entry assigned to it. When I click on the orange trigger text on the left panel of the interface it says 'no layers or replays assigned to this trigger'. The seqence does play immediately if dragged into the record interface but then does not play when you click record. Clearly I am setting the trigger in the wrong manner. I think. I doesn't appear possibel to select the length of the smoke sequnce in the timeline and set a replay. Also it it possible to reposition such a sequence on the screen? I don't see that the paramters for moving the sequence around like any other object at all. Thanks so much.

TOPICS
How to , Rigging

Views

61

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

There are different types of triggers. The triggers panel I think only shows triggers that make a layer appear or disappear, and no layers have been dragged into the defined trigger for 'h' (so it is empty). Cycle layers can also be triggered by key strokes, and can listen to the same keystroke ('h' in this case). So if the cycle layers works okay, I suspect you can just delete the "Trigger" in the trigger panel. Otherwise, drag the layer with the cycle layers behavior and drop it on the trigger so it is bound to something (that way the layer will be hidden until you press 'h').

 

It is a bit confusing that the triggers panel is only for... for... umm... "make layer visible" triggers. (I don't even know if they have a name!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Thanks for the reponse. How do you drag a layer onto a trigger? In record mode I can see the layer with the cycle that was imported both up top by where it says name and on the bottom where it says Timeline Scene, but neither can be clicked on and dragged onto where it says drop layers, replays, or audio here to create triggers. That looks like to me like oe it would work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

You have to be in "Rig" mode - its part of the puppet rigging. I actually suspect you just want to delete the trigger from the "Triggers" panel, but to add a layer go into Rig mode, the drag the layer from the hierarchy panel over the name of the trigger in the trigger panel (its the easiest way anyway!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Hmmm I can go to rig mode when that layer is selected and I see it shows the indivdual images in the sequnce which I can drag onto the trigger panels below but it doesn't bring it in as a sequnce. Clicking on the name of the sequence I am unable to drag that in. How do you get the whole sequnce into a trigger? Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Ooops! I was doing it from memory and got it wrong. Cycle layers can fire when the layer is triggered. There needs to be a trigger bound to the layer.

 

I don't understand why that trigger is orange. There are no listed layers in it. I would delete that trigger and start again. Click on the trigger in the trigger panel and press the DEL/Backspace key and it should go away. Then in rigging hierarchy find the layer with the Cycle Layers behavior added, then click the "+" button just to the right of the "Cycle Layers" behavior lego block and select "Create Trigger" from the popup menu. That should create a new trigger in the triggers panel and bind it to the layer (you should see the path to the nested layer under the "Layers and Replays" heading.

 

Note: The drag and drop should have worked (I just tried and it was fine for met), but if the orange trigger is in some weird state, that might explain why it was playing up. (I.e. a bug.) Delete it and start again is my suggestion. Normally it goes orange if there is a layer it is bound to, and that layer goes away (e.g. due to the PSD hierarchy changing during editing).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Hmm, okay I see the plus sign all the way on the right on the rig panel. When I import the sequence it appears as its own layer in the record interface. Swicthing to Rig I see the three images in the cycle. Mind you I imported the sequence not the images indivdually. Clicking the + signs brings up an orange word trigger even before a keysroke is applied, meaning something's wrong obviously. It doesn't matter if the first imahe in the sequence is picked or not, same result wither way. This would be the normal procedure right? See attahced, maybe you will someting I'm missing. Oy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Ah! Thanks for the screenshot! I always have a single root layer in a puppet, then put things under that. So group the three layers under a parent "Smoke Layers" or something, then put the cycle layers and trigger on that layer. I am not sure you can put cycle layers on the puppet root like that and make it work (never tried, but I have never triggered a "puppet", only "layers inside a puppet".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Not sure I follow you. When I import the cycle the app puts the cycle on its own layer in the record interface. It's not a layer inside the puppet unless it comes from photoshop I would think. Actually the layer will go behind the character in the final but I placed it on top so I can see it as the app places it in the middle of the screen behind the chartacer by default. Moving it down makes no difference. In the rig panel if i drag a single one of the three layers onto the trigger it does work and trigger stops being orange. But only one image appears not the cycle. If I make a trigger by pressing the + I can drag all three images into the blank trigger set but again only the first one plays and it stops being orange which is porgress I hope. When you say group the three layers is this what you meant? The images in the sequence are layers? I notice in rig mode the trigger appears there but in record mode on the right side while the paramters are set the trigger does not appear there. And the trigger does work but only with the first image. Banging head on compyter desk, lol.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Are you saying I should put all the smoke layers in a layer inside the photoshop doc and then try to cycle it from within the main puppet? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Well as a workaround this will solve the issue for me for now per your idea. I made the smoke inside the puppet itself in photoshop in a group, applied the trigger to that layer, then added the cycle behavior and changed the frames duration to 2. So I can animate the smoke. However from what I see you should be able to import a cycle of images and the app should treat it more like a single objest which can go thru the cycles based upon a trigger and have it be on a separate layer of its own which would be easier. But following the adobe and other tutorials it doesn't seem to work it only plays one frame even with the cycle behavior enabled. But as I always say if a workaround works use it. Thanks you for your kind attention and generous patience helping me resolve this. If I figure the solution to this working the way adobe suggests it could on it's own layer I will post it here. You're the best. Much appreciated!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

LATEST

Glad you got something going! I know there are "shared puppets" that allows a "puppet" to be shared (including artwork in it). But "Cycle Layers" to my knowledge only cycles through layers in the same file (not separate image files). It is common to put everything for a puppet in a single PSD file (so lots of layers). Its certainly not useful for like video clip length, but a few frames (like smoke) its designed for.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines