Is this corrupt save file recoverable?

New Here ,
Mar 14, 2018 Mar 14, 2018

Copy link to clipboard

Copied

Hi,

I had a power outage today and lost a lot of work on a puppet. I have one backup but stupidly hadn't created a second. I keep my save file on a secondary drive so assumed it would be OK. I didn't anticipate a power outage corrupting the file however. Would it be possible for someone to look at the file for me to see if it is recoverable? As I have no idea how to do that. The error message is "Corrupted loose reference file: refs?heads/master)returned from git_revparse_single(&headp,repoP, specZ)".

If this is possible I can send the files or link to them via a PM. I don't want the puppet publicly accessible.

Thanks so much for any help.

Views

1.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Mar 22, 2018 Mar 22, 2018

Yes, please send me a direct message with a shared link to the exported puppet (select the puppet in the Project panel, then choose File > Export > Puppet to save it as a self-contained .puppet file). We'll have a look.

Thanks.

Likes

Translate

Translate
Adobe Employee ,
Mar 22, 2018 Mar 22, 2018

Copy link to clipboard

Copied

Yes, please send me a direct message with a shared link to the exported puppet (select the puppet in the Project panel, then choose File > Export > Puppet to save it as a self-contained .puppet file). We'll have a look.

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2018 Apr 28, 2018

Copy link to clipboard

Copied

I also had a crash that resulted in my project file being corrupted.

Is there a way to recover a corrupted project? This one has a lot of work in it...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 30, 2018 Apr 30, 2018

Copy link to clipboard

Copied

Can you provide a .zip file of your project file, along with any artwork files that might not exist in the project folder? Share a link via Dropbox, Google Drive, etc., and we can investigate. Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

I have the same problem. Can you take a look at my files to?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

Can you provide a .zip file of your project folder, along with any artwork files that might not exist in the project folder? Share a link via Dropbox, Google Drive, etc., via direct message if needed, and we can investigate. Thanks.

Also, please include info about your operating system and version of Character Animator you were using.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 15, 2018 Nov 15, 2018

Copy link to clipboard

Copied

Same issue here. Is there an official path we can take to resolve this issue vs posting to this thread?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 15, 2018 Nov 15, 2018

Copy link to clipboard

Copied

There is a link at top of forums for reporting bugs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 15, 2018 Nov 15, 2018

Copy link to clipboard

Copied

For anyone dealing with this issue... First zip your project just in case. Next, rename your Ch Data/repo.noindex/objects/odb.sqlite3 to odb.sqlite3OLD.  Next, rename your conflicted file (ie. Conflicted copy from.... .sqlite3) file to odb.sqlite3

Now try opening the project again and it should work. For whatever reason, CA is creating a conflicted copy even when working on a single machine. It's possible it's creative cloud related since that's the directory we are using.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 16, 2018 Dec 16, 2018

Copy link to clipboard

Copied

Hi there,

I'm getting the same error:
Libgit2 error 1(4?Corrupted loose reference file: refs/heads/master) returned from git_revparse_single(&headP, repoP, specZ)

Also happened to me after a crash while working in Illustrator.

It's affecting both my primary file and a backup. Both use the same Illustrator file as a puppet.

I tried the solution above but my project folders don't contain any sqlite3 files.

cheers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2020 Jun 09, 2020

Copy link to clipboard

Copied

Hi, I am getting a similar problem. I did not have a power outage although my Character animator was working fine and then later today this project stopped opening and says this. It also says on the file has zero bytes. Is there any way of bringing it back?Screen Shot 2020-06-09 at 5.56.31 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2020 Jul 09, 2020

Copy link to clipboard

Copied

LATEST

Leaving this solution here for anyone that has tried everything on the adobe forums and isn't getting lucky. I found this solution on youtube by a guy called Alvin Yen... The video is a bit hard to understand, but it worked for me. The solution is simpler than it sounds, it took me about 3-4 minutes, including downloading the simple piece of software.

 

1. Backup your project file just in case.

2. Download SQLite (free software, DB Browser for SQLite)

3. Open SQLite, click on "Open Database" and open the "odb.sqlite3" file located in Your project>Ch Data>repo.noindex

4. Click on the "Browse Data" tab on SQLite, then go under "Size" and filter for the value 252 (type "252" where it says "Filter") 

5. If you have multiple results, click the top result where it says "BLOB" (under the "OID" tab, it might say something else)

6. On the right side of the window, under the "Edit Database Cell", make sure the Mode is set to "Binary"

7. You should see a code that looks like this "00 01 2c e9 af 58 78 95 aa 85 c4 cd 96 5a 11 ed 70 08 28 16" in the "Edit Database Cell". If not, make sure you clicked at the correct box of the result. The value will probably be split over two lines.

8. Copy that code (Make sure you get all of it, and check that it's correct)

9. Go to the "master file" located in "Your project>Ch Data>repo.noindex>refs>heads" and open it with a text editor (ex. Notepad or Notepad++)

10. Delete any text that might exist in it, and paste the copied code (remove any spaces if they are not removed automatically, and make sure it's in a single line)

11. Click save and try to open your project again.

 

As far as I understand, this essentially tells Character Animator to load the exact previous autosave, which will solve the problem if your last save became corrupted for some reason. This worked for me and I only lost the past few hours of work instead of the weeks of work I had in that file. Hope this helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines