• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Issues with blink

Community Beginner ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Hello,

 

I have tried to set up a blink effect using cycle layers but several problems are occuring at once:

Video here: https://youtu.be/Rh2R4E5AgVY

screenshot1.PNG

 

As you can see I have several issues:
1) The eyes don't blink together. despite having the "blink together option selected"

blink together.PNG

2) Despite having a transparent artwork the pupil and whites are no longer visible

transparent.PNG

 

Here is a screenshot of the layers I currently have (10 blink images, 5 unique images then duplicated to go in reverse) The trigger command was a test to see if it would work better on a trigger. It did not.
rig screenshot.PNG1.PNG2.PNG3.PNG4.PNG5.PNG

TOPICS
How to , Rigging

Views

51

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

I would carefully check the Cycle Layers behaviors for the two eyes. https://helpx.adobe.com/adobe-character-animator/using/behaviors/behaviors-layer-swapping.html#Cycle.... For example, one blink looks twice as fast as the other, so I wonder if you have a speed setting wrong.

 

Note that cycle layers have an automatic reverse which means you don't have to duplicate the images if you don't want to.

 

I suspect you have the settings wrong and you are seeing things like the next blink triggering while the previous one is still playing (because it is slow to blink) which might case it to stop.

 

If you cannot work it out from there, I would suggest finding an Adobe sample puppet with cycle layers on blink and copy those settings. My guess is it is the Cycle Layers settings that is your problem, including minor differences between the two eyes. (Also check the tags on layers - another common source of problems when stray tags are around the place.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Thank you that helped with the first problem (one cycle layer had a cycle pause and the other didn't. 

 

I'm still having troubles with the second problem. Specifically the visibility of the  pupils and eye whites when the blink happens.

 

Thanks,

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

LATEST

I figured out my issue and thought I'd post it in case anyone else had the same problem. Since I had my blink cycle in a "blink" layer it was hidding the rest of the art in the group. I had to add it to it's own sublayer within the eyegroup called "lids".

 

lid layer.PNG 

 

My eyes work fine now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines