Lip sync not working when the character turns their heads

Explorer ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

Hello Beautiful People,

Thanks to this software I have more than enough to keep me entertained during this challenging time. I hope you and your families are well.

My problem today is I have several characters in a room talking to one another. I have rigged them all with the head turner behavior. It all seems to work fine except when I record head turns. The lip sync stops when they turn their head. It only works when the character is facing forward. First I posistioned the characters, added audio and lip sync, when I recorded head turns the lips stop moving when they turn their head. Why? I rigged the charcters modeled of the walker puppet. If anyone can help me I would very much appreciate it. Thank you.

TOPICS
How to , Puppet movement , Rigging , Tips and tricks

Views

1.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

LEGEND , Apr 04, 2020 Apr 04, 2020
So you have a walk behavior (with profiles) and head turn behaviors (with profiles). One suggestion is to click on the layers where you added the behaviors then look at the properties panel (on the right). Look for the behaviors added. I would expand the "Views" and "Handles" etc sections and see if they are binding to the right things. E.g. has the root puppet walk behavior connected to the correct layers for the profiles? Then for each head turner behavior on a profile, does its Views section ...

Likes

Translate

Translate
Participant , Apr 04, 2020 Apr 04, 2020
Cool puppet. Your structure looks correct - for what I can see. One quick idea is to turn on 'Show Rigging Issues'. It's the little Triangle '!' symbol at the bottom of your rigging window. That may give you a clue. If the head turner is working, then Character Animator must be recognising the various head views. Are your blinks and pupils working? If they are working, it sounds like something is conflicting with your mouths. Perhaps a naming problem? Double check that all the mouth shapes are n...

Likes

Translate

Translate
Participant ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

Hi Opiphus,

You need to rig each head position the same as your front head. So use the same structure and let character animator know that this is your mouth group, eyes etc. Make sure you're naming is correct too. Sometimes if you are just copying and shifting things Illustrator will add 'copy' to the layer name. Like 'Ah_copy'. That will confuse Character Animator.

If you continue having issues you may need to post a screenshot of your setup.

 

We have recently released puppets that have head turner being applied to front and 3/4 views as well as walk ability. So if you are looking for a puppet to copy the structure - have a look at the 'Flat Pack' puppets.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

Smidio,Thanks 

I went through and did everything you stated above to no avail. 

Please take a look at the screenshots. Maybe you can see what i dont.AI.jpgch.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

Cool puppet. Your structure looks correct - for what I can see.

 

One quick idea is to turn on 'Show Rigging Issues'. It's the little Triangle '!' symbol at the bottom of your rigging window. That may give you a clue.

 

If the head turner is working, then Character Animator must be recognising the various head views. Are your blinks and pupils working? If they are working, it sounds like something is conflicting with your mouths. Perhaps a naming problem? Double check that all the mouth shapes are named correctly.

 

Try going into one of the problem Head Profiles and see if the mouth group is being associated with the right mouthshapes. As you select each mouth shape it should highlight blue on the right of screen.

 

Also have you created any triggers for mouths? (Smile, Angry etc.) Sometimes an issue like this can be a conflict there. Best to make an alternate folder called 'Alt Mouth' and put those in there - then use swap sets to switch between your mouth set and any alternate mouthsets.

 

Hopefully we are getting closer to solving your issue!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

So you have a walk behavior (with profiles) and head turn behaviors (with profiles). One suggestion is to click on the layers where you added the behaviors then look at the properties panel (on the right). Look for the behaviors added. I would expand the "Views" and "Handles" etc sections and see if they are binding to the right things. E.g. has the root puppet walk behavior connected to the correct layers for the profiles? Then for each head turner behavior on a profile, does its Views section connect up as you expect? It might give a hint of what thing is binding through incorrectly.

 

My guess is a higher level behavior is binding through to lower level layers instead of the ones you want. Checking all the Views and Handles etc to make sure they bound to what you expected can sometimes give a lead as to what the problem is.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 05, 2020 Apr 05, 2020

Copy link to clipboard

Copied

LATEST

Thanks to both of you that answered. I'm learning alot and appreciate all the help I am getting from this valuable community. The problem was I had the mouths inside an extra layer. Once I took them out of the extra layer they worked great. It won't be long before I can start helping others in this community as well. It's been since feb 21, since I started using all adobe products and will be completeing my first episode very soon. Thanks All.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines