Photoshop changes not showing in Character Animator Record Mode

Community Beginner ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

Hello, 

Thank you in advance for reading my post. 

I am adjusting the Cassandra puppet from OK Samurai in Photoshop. When I click Save and return to Character Animator, the puppet has the updated changes showing in Rig Mode. But the Cassandra puppet in Record Mode still shows an earlier version of the puppet. Therefore, I cannot create a scene of my new version of the puppet. I've tried multiple times with no luck. I also tried the following

  • Check that Auto sync with art work and puppet path were accurate
  • Opened CA and PS separately. Changes made in the independently opened PS still only save to Rig Mode in CA

I attached the CA file here. I'd appreciate any expertise in resolving this issue.  My changed version of the puppet should be showing in Rig Mode: eyes aren't open as wide, navy blue shirt, etc. 

Thanks

Amit

TOPICS
Bugs

Views

169

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

Did my attachment come through? I tried multiple times to attach the file, but I'm not sure it worked. And it won't let me go back to edit the original post. 

I dragged the file onto the correct area and it just disappeared. I also tried browsing to it. Same result.

Thanks

Amit

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

There is a size limit on attachments - sometimes better to upload to google drive / dropbox etc and share the download link here instead. (I cannot see an attachment.)

 

If you can see the changes in rigging mode but not when recording, my *guess* is it's either it is something like a swapset hiding the bit you changed, or you have two puppets in your project and you are not editing the one you are using in the scene. But certainly looking at the puppet can help. Screenshots can also help spot problems.

 

Oh there is also a refresh button under the scene, where i think if you shift-click (or was it alt-click... try both!) it flushes more internal caches just in case something got stuck.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

Hello, 

Thank you for the response. I tried the refresh item but it didn't work.  I created a google link with the files:  https://drive.google.com/drive/folders/1kKaLKj8TupMh81uawNjckVOUTpqbpP7q?usp=sharing

Are you able to see the files?  

I managed to get the old puppet into the navy blue shirt, but she won't update with any of my other settings: narrower eyes, etc. 

Thanks

Amit

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

This is what I see. 

 

If I go into your project under the Gathered Media 1, 2, and 3 folders, I see about 4 different Cassandras - there should really be only one. The first Gathered Media has one with the blue shirt and one called "copy" with the blue shirt and glasses. My guess is you just need to relink to the correct version. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

Thank you for the response.  

I went in and deleted all the other casandras and there is only one left in one folder: Gathred Media.  

I then went into CA and opened the character in PS. I made a change and saved it. I even checked the path in PS and it saved it right to that Gathered media folder. 

When I went back into CA, the Rig Mode had the new character, but Record Mode still has the old one. I checked the path in CA, too. (screenshot below)

Amit_Goel_0-1632883834363.png

 

It's weird.  If I deleted all the other instances of the puppet, where is it reading that old puppet from?  Is there another path in CA that the old version of Casandra is reading from? 

You're very kind to keep helping me, though! 

Any thoughts now?  I changed out the files in that google drive location with my updated ones if that helps. 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 29, 2021 Sep 29, 2021

Copy link to clipboard

Copied

I think you actually are seeing the correct file, but triggers are taking over and not showing what you expect. So currently in Rig mode you have frame 2 of the "happy eyes" trigger visible. That's a temporary frame that isn't going to show up (if you press the 5 key in record mode you'll see it in action). You would need to change the layers "Right Eyeball" and "Left Eyeball" to have the visuals come through.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2021 Sep 29, 2021

Copy link to clipboard

Copied

Thank you for the response. 

I see the happy eyes when i click "5" in Record Mode...

Amit_Goel_0-1632933053250.png

 

...and I see what you are talking about with the frames in Happy Eyes...

Amit_Goel_1-1632933119966.png

 

But I'm unsure what to do when you say, "You would need to change the layers "Right Eyeball" and "Left Eyeball" to have the visuals come through." 

 

Change them in what manner?  I played with right/left eyeball layers a bit, but nothing works to get Record Mode to look like Rig Mode. 

 

I apologize, but I'm sure this is is just my ignorance about the program. I'm still learning.  

Can you be more specific when you say to change the layers?

Thank you

Amit

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 29, 2021 Sep 29, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 01, 2021 Oct 01, 2021

Copy link to clipboard

Copied

LATEST

Thanks SO much for this. It really helped explain things. I was able to do all the manipulations in PS and bring them into CA. 

I have never been on the Adobe message boards before and I wasn't aware that requesting assistance was so easy and efficient.  

Thanks again!  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines