Progressive performance drop due to Replays

New Here ,
Feb 06, 2021 Feb 06, 2021

Copy link to clipboard

Copied

I have a rather complex puppet with a number of replays. For example, a replay to apply a transform behavior to all components of the face to simulate a nod or looking down.

 

My PC can comfortably handle a framerate of more than 24 in the record and perform tabs. However, while testing the replays, I noticed that at one point it the frame rate dropped below 24. From there, as I continued testing replays, the frame rate continued to drop in direct relation to the number of replays that had been triggered (Note that all are less than 1 second in length). Refreshing the scene resets the frame rate to above 24, but triggering a certain number of replays make it progressively drop again. 

 

I've also noticed that as performance dramatically decreases, the memory consumption of Character Animator as well as CPU usage does NOT increase.

TOPICS
Bugs , Freeze or hang

Views

96

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 06, 2021 Feb 06, 2021

Copy link to clipboard

Copied

Hi, I am not sure I can answer you question, but it does point out (I think) that CH rendering is based on your GPU  ability and not so much on CPU and memory.

 

Be well fellow puppeteer, - Platty

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

YES!! I have noticed this too!!! I'm glad I'm not alone on this. The longer I stream, or the more replays I enact, the more frames get dropped over time. Been monitoring my CPU and RAM usage and these don't seem to be anywhere close to being the problem. Sure hope we can get some answers on this one.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 09, 2021 Mar 09, 2021

Copy link to clipboard

Copied

LATEST

Thanks for letting us know...I'm not sure why this would happen, but it sounds like a bug. We'll take a closer look.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines