Puppet not bending arms in version 22.5

Community Beginner ,
Jul 04, 2022 Jul 04, 2022

Copy link to clipboard

Copied

My version of character animator updated to 22.5 recently. I have been relying on the Chibi puppet from the puppet maker for my projects, and all of a sudden, she cannot bend her arms. I checked the rigging of the arms but it seems normal just like any other puppet, I checked the limb IK but nothing I did changed the fact that her arms stay strait and only do a glitchy ultrafast bend at unpredictable times. 

 

I have version 22.4 on my desktop and the same puppet does not have these problems. What should I do?  I mean, other than working on the desktop from now on...

TOPICS
Bugs , Puppet movement

Views

69

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jul 05, 2022 Jul 05, 2022

Ok I solved it! Disabling walk behaviors as a whole didn't work but I started messing with each walk behavior setting. For some reason, in my case, if I uncheck the box "pin feet while standing" the arm moves again. I wish I understood why, but even the support person I contacted didn't know.

Likes

Translate

Translate
Explorer ,
Jul 04, 2022 Jul 04, 2022

Copy link to clipboard

Copied

I seem to have the same problem but only on the Quarter and Profile views. My frontal is working as expected. Puppets were working fine in earlier versions!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 04, 2022 Jul 04, 2022

Copy link to clipboard

Copied

Removing walk behaviour fixed the arms. Seems like walk is interfering with elbow detection?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 05, 2022 Jul 05, 2022

Copy link to clipboard

Copied

unfortuantely When I remove the walk behavior it doesn't fix the arm bend issues on my puppets. I'm just using stock puppets from the character making tool.  They work at first then they start breaking in version 22.5. I'm considering downgrading for now to the prior version since that is working well still.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 05, 2022 Jul 05, 2022

Copy link to clipboard

Copied

LATEST

Ok I solved it! Disabling walk behaviors as a whole didn't work but I started messing with each walk behavior setting. For some reason, in my case, if I uncheck the box "pin feet while standing" the arm moves again. I wish I understood why, but even the support person I contacted didn't know.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines