Puppet quality when importing into After Effects

Community Beginner ,
Jul 04, 2017 Jul 04, 2017

Copy link to clipboard

Copied

I created my character using Illustrator as vectors, but when I import the Character Animator puppet into After Effects there is no option to "Continuously Rasterize". So when I zoom in to the character's face, it gets blurry as a bitmap would.

Are there any workarounds for this?

Thanks!

Views

4.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 05, 2017 Jul 05, 2017

Copy link to clipboard

Copied

Select the puppet in the Project panel, then make sure "Render as Vector" is checked in the Properties panel.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 06, 2017 Jul 06, 2017

Copy link to clipboard

Copied

I tried that, and I think that only works within Character Animator. Once I import a puppet's chproj into After Effects, and I zoom into the puppet 200%, it's still blurs like a bitmap.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 08, 2017 Jul 08, 2017

Copy link to clipboard

Copied

Ah, yeah, content via Dynamic Link (either from Character, Premiere Pro, etc.) is pixels only at this time. I've added your request to the existing one for this capability.

For now, you would need to scale it using the Transform behavior in Character. (If you have CH and AE open at the same time, and you just dragged the CH scene from its Project panel into AE's Project panel, you can flip back to CH to adjust the Transform > Scale values, then switch back to AE to see if OK.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 12, 2019 Feb 12, 2019

Copy link to clipboard

Copied

Jeff Almasol​ has this been resolved? i am having same issue. When i zoom inside of after effects to 300% it gets blurry. the character animator puppet size has been maxed out to fit the screen.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 12, 2019 Feb 12, 2019

Copy link to clipboard

Copied

There is no change here, sorry -- content over Dynamic Link is pixel, not vector, data... so zooming into the composition in AE won't rerasterize the CH source content.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 12, 2019 Feb 12, 2019

Copy link to clipboard

Copied

thanks for the reply. thats so frustrating. i'm using AE because CH animator doesn't have the most basic feature: a zoom-in camera. and while I can zoom in in AE, I still cannot get the desired result. 1 work day later im back at square 1.  Is there another suite of software that works? doesnt have to be Adobe.

Or is there a work around, to the work around to the underwhelming software?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 12, 2019 Feb 12, 2019

Copy link to clipboard

Copied

If your puppet is based on Illustrator artwork, select the puppet in the Project panel and then either increase the raster Resolution value from Default (200%) to something higher (in the Properties panel) or try the Render as Vector option and then scale the puppet in CH using the Transform behavior (see mention above).

We're aware that cameras would be important. We're tracking the feedback for this topic on our User Voice site:

parallax 3d and cameras – Adobe video & audio apps

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 12, 2019 Feb 12, 2019

Copy link to clipboard

Copied

Thanks. when i clicked the rendor as vector option, the color of the artwork changed. I do not understand why this happens. When i increase to 400 resolutions still have same problem. My work flow sucks. I have to zoom in and out of after effects and then zoom in and out of after effects. this is terribly inefficient. CH has so much promise too

Screen Shot 2019-02-12 at 7.18.31 PM.pngScreen Shot 2019-02-12 at 7.18.45 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 02, 2019 Dec 02, 2019

Copy link to clipboard

Copied

Adobe CC 2020 has been released, has this problem been addressed in this latest version or is it still queued?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 12, 2019 Feb 12, 2019

Copy link to clipboard

Copied

Have you tried changing the scene resolution to something bigger? Eg times 4 The final resolution. Then you are effectively zooming out rather than zooming in. Might be slower, but worth a try?

You need to be careful as thin lines can disappear, but I think it should work if your100% to  300% zoom range becomes 33% to 100% zoom. As soon as you zoom more than 100% I think you may be in trouble.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 25, 2019 Feb 25, 2019

Copy link to clipboard

Copied

Thanks for the suggestion however after trying to increase zoom range, the render time is unbearably slow. how can such a simple feature be overlooked? ZOOM is not possible without a degradation of quality and/or massive slowdown in rendering. I would have to  upgrade my workstation for Zoom functionality and multiple workarounds. Thats ridiculous. Improve the functionality, give us ZOOM Jeff Almasol

so frustrated by the lack of this most basic functionality

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Personally I do all the zooming in CH. I am pretty sure CH -> AE is as bitmaps, not vectors. So zooming in AE is zooming the bitmap. If you did any scaling in CH rather than AE then it should not lose resolution.

If making the bitmap high resolution is too slow, then only other approach I think is to try to do the scaling in CH instead of AE. But I could imagine a bit tricky to get right if you start trying to rotate the CH output or do other fancy things with it. E.g. if you scale in CH and it crops at the edge of the screen, then you need to make sure that does not become visible in the final video.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Yeah, as alank99101739 mentioned, Dynamic Link between any pair of apps is currently just bitmaps (pixels), so additional support would need to be added for vectors. For now, I've added this thread to our internal tracking of this request (i.e., continuous rasterization of a Dynamic Link source).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2019 Mar 12, 2019

Copy link to clipboard

Copied

It would be most helpful to add vector support to dynamic link.  I'm sure there are significant technical challenges to achieve that.  Is there anything to report on any progress in bring that feature forward?  The escalation is 19 month old.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 30, 2019 Jul 30, 2019

Copy link to clipboard

Copied

I have the same problem, but what is real weird is that I have multiple puppets that I created in Illustrator using the same scale of size, imported them into Character Animator and only discovered the concern while importing the scenes into AE.  One puppet looks great, but another looks like garbage...and they are scaled the same in AE and I have tried using the scene width and height to compensate, but it seems to work the exact opposite from what I need.  When I make more resolution in the CH, it only makes the puppet smaller in AE.  This is crazy-frustrating.  I created the puppets in Illustrator to avoid this issue of pixels...but now I am being forced to deal with them because of the dynamic link.

Will there ever be a good solution?

John

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 02, 2019 Dec 02, 2019

Copy link to clipboard

Copied

The latest release made it at least a bit easier to zoom inside CH now - there is "camera" controls now, so you can zoom the camera in on the face much more easily than before. That plus keyframing in the 3.0 release I think is the best answer you have for now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 16, 2021 Apr 16, 2021

Copy link to clipboard

Copied

I found a decent workaround. But this is my first puppet; so pardon me if my language isn't quite proper - still despite my wording, the workaround does actually work. After watching Okay Sumarai's "Making Your First Cartoon" on YouTube, I definitely wanted to get the kind of cool results that he achieved by enlarging his puppet for close ups. But once in AE, I had a similar experience as others have reported: my puppet's resolution went to garbage as soon as I tried to increase her scale for a close up. So (1) I made my puppet gigantic in Character Animator by clicking on the puppet herself then going to properties and increasing her Transform/Scale. But her head and feet looked cut off after I did this. Still I imported her into After Effects and, you guessed it, head and feet cut off there too. So (2) I went back to Character Animator and clicked on the scene and increased the height and width of the scene itself. And that did the trick. Once in After Effects again, my character can be huge or small and her resolution is great. -- Now mind you once in AE, the parameters of the Character Animator puppet file size (not the visible puppet herself) but the rectangle representing her actual file size in After Effects is bigger than the project's composition size. Still she seems to be rendering at the same speed as she did when her file size was smaller -- and she looks clear.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 21, 2021 Apr 21, 2021

Copy link to clipboard

Copied

I think, what is happening is, the Illustrator file is rasterized using the artboard sizing in pixel. The document raster settings do not affect the outcome. So my best practice is, setting up the Illustrator file using pixel measurements equivalent to my stage setting in CA. For a Full HD project I use a 1920 x 1080 pixel Illustrator template. Now you can use the Quality Selector in CA (50%, 100% 200%-Standard or 400% high) and it does exactely what you would expect. With 200% your Artwork can be resized 2 times before loosing resolution. If you need more Zoom reserve than 400% you have to increase the Ilustrator Artwork Size. The puppet is not restricted to illustrators artbord boundary.

That said, it is strange, that you still need to find workarounds for such simple tasks at Version4.0!

I do guess, that the core engine is set-up like this and nobody want to touch it, i suspect it might need a complete rewrite of the illustrator import handling.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 16, 2021 Jul 16, 2021

Copy link to clipboard

Copied

LATEST

Iulstrator file size is irrelevant as it is vector.

Create your puppet in illustrator

Improt it into Character Animator.

Do your thing with it etc

Choose Render as Vendor (Note: Any Gaussian blur effects etc in the Illustrator file will be ignored once clicked)

Save the project

Open After Effect

Import the CHPROJ file and put it into the timeline

Everything should be synced

Make a change to the puppet in Illustrator, save, switch to Character Animator, the chnages should update, switch to After Effects, th echnages should update, They are all linked.

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines