Puppet won't stop walking

Explorer ,
Oct 10, 2018 Oct 10, 2018

Copy link to clipboard

Copied

As the title says: My puppets won't stop walking. The walk-behavior is set to move only when pressing the arrow keys (in both rig mode and record mode). But when I deactivate recording the walk behavior my puppet starts to walk immediatly. This makes recording the dragger impossible! I also can't record any bodyspeed, because while pausing, the puppet simply walkes outside the frame. And finally, and most infuriating, when I want to look at my recorded session, while simply moving frame by frame through the scene, it also walks, regardless whether walking is recorded in this particular frame or not. I saw a tutorial where Dave Werner stopped in the middle of a step.

What am I doing wrong?

EDIT: I disabled the eye-symbol on the right, so it won't walk at all, this helps with recording the dragger-behavior, but not with my other problems.

Views

315

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Oct 10, 2018 Oct 10, 2018
The walk behavior (and other physics behaviors) are like this unfortunately. When “on”, the behavior does its thing - when “off” it does not. But on/off, as you note, is not intuitive unfortunately.If you are recording and have that behavior armed, it is controlled by your keyboard. Otherwise it is controlled by the current scene and playback position - even if paused.If you can get the job done with the restrictions above, go for it. However the best advice I have seen (I don’t use the walk beh...

Likes

Translate

Translate
LEGEND ,
Oct 10, 2018 Oct 10, 2018

Copy link to clipboard

Copied

LATEST

The walk behavior (and other physics behaviors) are like this unfortunately. When “on”, the behavior does its thing - when “off” it does not. But on/off, as you note, is not intuitive unfortunately.

If you are recording and have that behavior armed, it is controlled by your keyboard. Otherwise it is controlled by the current scene and playback position - even if paused.

If you can get the job done with the restrictions above, go for it. However the best advice I have seen (I don’t use the walk behavior much myself) is

* Remember that the refresh button puts the character back to its starting position (based on Position X/Y properties)

* If you understand when the keyboard takes effect, you can stop it walking around by enabling recording or disabling that track (unclick the “eyeball” symbol)

But its still painful. So my best suggestion is really

* Turn off the body movement so it just walks in place

* Use the Transform behavior with blends to make the puppet move instead of the built in walk behavior

Doing this you get more control over when the puppet moves or does not move.

This is one behavior that I think Adobe should look at controlling from the timeline so it works out the current body position frame relative to the start of the take. You should be able to compute the position and position of knees, feet, etc based on a time delta from the start of the take. Some of the other physics behaviors this is really hard to do - because objects may bounce off other objects - but I think the walk behavior is deterministic and not dependent on other objects in the scene. Until then, I recommend turning off body movement and using blends of Position X/Y recordings to move the puppet around. Only use the body movement setting if you are doing a live stream.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines