• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Red dots and keyable parameters lost! In scene mode my properties panel looks like rig mode instead.

Community Beginner ,
Aug 20, 2020 Aug 20, 2020

Copy link to clipboard

Copied

I keep having this glitch regardless if I am using one of my own characters or an okay samurai puppet. I have my puppet rigged, I put the puppet in a scene and everything is great. At some point, (I htink when I update the Illustrator or Photoshop file), I go back to the scene and the properties panels no longer lets me activate or deactivate properties from recording and none of the attributes are keyable. I attatched a photo. The one without the red dots is the one I am refering to. If I delete that scene and put my character in a new scene I have the red dots again. This is ok if I don't have animation in a scene, but horrible in shots where I do have animation and I want to continue adjusting things. Does anyone know a fix? 

TOPICS
Bugs , Dynamic link

Views

454

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 20, 2020 Aug 20, 2020

Copy link to clipboard

Copied

Can you provide a full screenshot of when it fails? To me it looks like you went from rigging to scene mode, but have not clicked on a puppet in the scene window so its still showing rigging properties instead of track properties. (The properties panel is reused by different things.) See the panel title as well? One says "track" and the other does not.

 

I think you just need to click on the puppet in the timeline panel and the properties panel will jump to that instance of the puppet in that track (instead of the shared puppet definition you edit in rig mode).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 23, 2023 Feb 23, 2023

Copy link to clipboard

Copied

OMG thankyou!! SPent hours. Clicking on the puppet in the timeline solved this for me

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 23, 2023 Feb 23, 2023

Copy link to clipboard

Copied

LATEST

It's quite confusing, but there are 2 different properties panels related to Puppets in Character Animator.

There's the Puppet Properties which is available when you have a puppet selected in the Project panel, or a layer or puppet selected in the Puppet panel. These are the settings that go with the puppet if it's exported or inserted into another scene. 

When a puppet is in the timeline, you can access the Track Properties by selecting the puppet in the timeline. This is the Properties panel with the keyframing capability. These properties are specific to the puppet in this particular timeline. You can push the settings into the puppet.

In short, select the puppet in the timeline to get the keyframe parameters you're looking for. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines