Trigger not working.... and the record panel not showing all my drawings. Bugs???

Enthusiast ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

So I am activing some triggers that I can't find a reason why they are not showing on the screen.

 

The timeline seems to have the triggers OK, but they are just not shown on the recording screen mode. 

 

What is going on? 

 

Also, the recoding mode isn't showing all my drawings.  I deleted and re-uploaded the Illustrator file and Character Animator shows them at first, then I make them not visiable to work on some items first, and then when I re-activate them to visiable only a few of them are showing. 

 

What could be the problem with Character animator only showing a portion of the drawings in the record mode? 

 

Here is for example all the drawings from Illustrator, and below it is the selection that Character Animator decides to show at whatever time.

 

Also, here a video of the triggers that are not showing.

https://www.youtube.com/watch?v=dJ6KUtLVXr0

 

 

snap1.JPGsnap2.JPG

TOPICS
Bugs , How to , Rigging

Views

343

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

Hmm. Nothing obvious from the video. Two layers next to each other, one triggers and the other does not. What I would be double checking is whether the 10in2 has any other tags on it.

 

Double check the trigger definition is bound to the correct layer. To do this, bring up the trigger panel, click on the first trigger, then look at the path down the bottom of the panel. This is the layer name it is bound to. Then click on the other trigger in the panel and look at its path. Looking at video it seemed like the 10in one is bound to "Balance/10in2" (bit hard to see, writing is small). I was expecting that to be the path from the root of the puppet (Scale/Balance/10in2). I am wondering if the trigger got disconnected somehow. If so, you can drag the layer back over the trigger in the trigger panel to relink them (clicking the little 'x' disconnects layers from the trigger). This avoids the need to re-record the takes. (If you don't need the recordings, just delete the trigger and start again from scratch.)

 

If you cannot work it out, can you open up trigger panel and show screenshot with trigger A in that panel selected,, then trigger B.

 

The other thing you can try is to turn on the "mesh" icon at the bottom of the scene window. Is it something strange like the writing has been transformed off the edge of the page? Or the opacity has been set to zero so its not visible?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

Animator is not showing parts of my drawing and I think that is why the trigger might not be working. 

 

Would there be a way to fix it so Animator could show my entire drawing from the document? 

 

Here is a video. 

https://www.youtube.com/watch?v=ZV5WyUgggE4

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

Are you able to export the puppet (the device?) and import into a new project? Does it work there? If it does not, are you able to upload to Google Drive or similar and share a link? I am happy to download and have a look.

 

Current suspicion - the last video showed the device flying in from the left into the scene. I am wondering if not everything is moving - e.g. some of the writing etc is still off the screen. So it is triggering, but the Transform or whatever you are using to move the object is not moving everything... perhaps. If you can share the puppet it might be faster to diagnose.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Aug 14, 2020 Aug 14, 2020

Copy link to clipboard

Copied

So if I make a new project the drawing seems to be showing up OK, at least at the moment, hopefully it doesn't go away later. 

 

I think I am going to have to create smaller chunks of the video in CH, and then put them together with my video editing software.

 

For this project I swear I had done some keyframe movements for animation, and suddenly they are not there anymore, and I have to re-do them again,  and now I am stuck because the second illustrator file is not showing completly.  I have tried delete this second illustrator file and then re-upload it to this project and still not showing properly. 

 

This first project is loaded with so many changes that maybe the software isn't liking it for some reason. 

 

Here is the link for the Illustrator file. 

https://drive.google.com/drive/folders/1vYnIOIJTpuB_O0axnbsQWWKu9eGx6CUy?usp=sharing

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 14, 2020 Aug 14, 2020

Copy link to clipboard

Copied

I create one "scene' per clip, render them separately, then join in video editing software. However there is one big database for the project that remembers undos etc. So it might be sensible to have one project to create the puppets, then export and load into a "clean" project to do the rendering from. You can then delete the old project once you are happy. There have been corruption bugs occasionally, or a power outage, so exporting puppets is a good idea as a form of backup regardless.

 

No idea why it went strange, but there are occasional bugs, so multiple projects (without going crazy) can be a good idea. If you lose one, you don't lose everything!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Aug 14, 2020 Aug 14, 2020

Copy link to clipboard

Copied

So....

 

It's not working :(.....  the same thing is happening again. 

 

I created a new project and imported the file and it's not working.

 

At first it shows all the drawings in the file, but then I make them NOT visible to start working on the recording one item at the time, and then when I make them visible again some of drawing show up, and some of them don't show up.

 

I think its something having to do with the visibility button from CH on each one of the drawing layers in the files.  I think once you make them not visible, and then try to make them visible again, some of the layers may or may not show up. 

 

I am going to save the illustrator files and restart my computer.

 

Is there a way to uninstall and re-install CH back from the Adobe CC system?

 

I think CH might have gotten out of wack after a sudden shutdown from my computer... then I started noticing missing things that I was thinking I had already done in the timeline, and now this other Illustrator file doesn't seem to be working correctly with CH.

 

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Aug 14, 2020 Aug 14, 2020

Copy link to clipboard

Copied

LATEST

NOPE...

 

It doesn't work even after I re-installed CH.

 

I restarted my computer and everything.

 

It works for some time showing all my drawings, but then CH just goes back at showing only portions of my layers from the file.

 

 

Is there a way to get to the Adobe people to see if there is a way for them to look at this closely?  

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines