Unable to import Character Animator to After Effects (2018)

New Here ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Each and every time an Adobe update goes into effect I become extremely worried because inevitably it does nothing but cause me a great deal of headache and loss of productivity. This time, it seems I can no longer import a Character Animator recording into After Effects 2018 (CC) because that functionality appears to have vanished (script) and any apparent help in rectifying the matter seems to be unavailable. I was not in need of an update and wish that updates were optional or at least come with the ability to be reverted to previous versions without further issue.

Now that I have voiced my complaint: I have uninstalled/installed the latest versions of both AE and CA but I am still unable to create a dynamic link between the two and the script that used to allow me to import CA to AE is no longer present. It seems I am now left with performing a standard import of CA .png sequences along with the import of the associated .wav files then painstakingly matching them together in AE. If there is a better way to accomplish getting CA (CC) into AE (2018 CC), I am eager to know.

Thanks. 

TOPICS
Dynamic link

Views

9.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 25, 2017 Oct 25, 2017
OK, with no Adobe apps currently running, launch Character Animator and wait for it to start up, launch After Effects, then try the import. Still the same issue?I'm assuming the .chproj was created in the latest Character Animator CC 2018 and not from an earlier beta version, correct?

Likes

Translate

Translate
Adobe Employee ,
Oct 24, 2017 Oct 24, 2017

Copy link to clipboard

Copied

Dynamic link is the preferred (and most common) way people are linking CH & AE/PR currently - if it's not working for you, that's a bug we need to know about. What happens if you try to import a .chproj into AE? If you get an error message please let us know.

You could also import the PNG/WAV xml file into Premiere and dynamic link that to AE.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2017 Oct 24, 2017

Copy link to clipboard

Copied

How do you import to after effects now that the New Comp from Character Animator Recording.jsx is gone from file>scripts. I can get the video to play, but the audio has to be imported separate and is a pain to line up with animation. The adobe help forums are obsolete on this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Dynamic link appears not to work...when dragging in or importing a .chproj file, there is no anything. Nothing shows as imported, and there is no error message.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Jerome-Gbruceb9981​ and nlemonc​ -

  • For dynamic link to work, both CH and AE or PR need to be the latest version (2018). If you've done that and it's still not working, it seems like a major bug - please send us a video or screenshot of what is happening.
  • If you need the old PNG + WAV AE script, here it is: https://t.co/V8LrJ7lhyq  - you can go to File > Scripts > Run Script in AE and this will let you do it the old way.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Both of my programs are up-to-date (2018). I'm having the same problems. When I drag or try to import a .chproj file, nothing happens.

AE_glitch.gif

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Can you try quitting all Adobe applications, waiting up to 30 seconds until the dynamiclinkmanager background process goes away in Activity Monitor, relaunch After Effects, then try again (either via Import File dialog box or by dragging in the .chproj file)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

I restarted my Mac, launched AE, and was able to import the .chproj file. It worked! Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Where did you install After Effects and Character Animator?  Please provide the file paths.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Hello Jim,

I installed in my Applications folder. (Is this what you were asking?) Thanks!

Screen Shot 2017-10-25 at 2.22.18 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

OK, with no Adobe apps currently running, launch Character Animator and wait for it to start up, launch After Effects, then try the import. Still the same issue?

I'm assuming the .chproj was created in the latest Character Animator CC 2018 and not from an earlier beta version, correct?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Yes, I used the latest Character Animator CC 2018.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

By the beard of Zeus, that WORKED!

FYI, my characters and scene were created in Ch beta version, then pulled into Ch 2018...don't know if this is relevant but thought you may want to know.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Which scenario specifically worked? Starting AE first after restart, or launching CH before AE?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

It worked after I launched Character Animator, then After Effects.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

I tried both scenarios and it worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Same as above for me. I've tried restarting my machine a couple of times.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 15, 2019 May 15, 2019

Copy link to clipboard

Copied

LATEST

Thank man!

The script works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

We're still trying to reproduce the error condition, but have been unsuccessful. Anyone have specific steps (starting with no Adobe apps running) that reproduces the issue?

If you have a repro scenario, can you provide specific OS version information, which apps are running, the order that they were launched, and if you were importing via drag-and-drop (using the mouse, or stylus?) or AE's Import File dialog box.

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 01, 2017 Nov 01, 2017

Copy link to clipboard

Copied

I believe I was in Character Animator beta first, but even when I closed it and opened Character Animator 2018, there was a bit of a snafu. Only after I closed everything and then tried opening Character Animator 2018 and then After Effects did Dynamic Link work. (And I dragged from Ch project panel to Ae project panel. I had tried both importing and dragging the first couple of times.)

As to what other apps were running at the time...possibly Photoshop and Illustrator. (I can't remember the order in which these were opened.) I'm in OS Sierra version 10.12.6

Hope this helps in some way!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 01, 2017 Nov 01, 2017

Copy link to clipboard

Copied

If the time between when you quit the Beta version and when you launched the 2018 version was less than 30 seconds, the older dynamiclinkmanager process (from the Beta version) might've been in play and AE CC 2018 might've been trying to use that. Dynamic Link is compatible between equivalent releases (e.g., CH Beta and AE CC 2017, or CH CC 2018 and AE CC 2018). Just a guess.

Thanks for that info.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2017 Nov 02, 2017

Copy link to clipboard

Copied

Hmm...that may have been it. Thanks, Jeff!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 27, 2018 Feb 27, 2018

Copy link to clipboard

Copied

I'm using windows and when I drag the proj file into after effects a window pops up - says its connected, but nothing happens, i've restarted, I"ve opened the programs as suggested. still not workingerror clip.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 27, 2018 Feb 27, 2018

Copy link to clipboard

Copied

After you select that scene in that dialog box, then click OK, do you get the scene in After Effects?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 27, 2018 Feb 27, 2018

Copy link to clipboard

Copied

the ok button is always grey, never becomes a button, but when I pull the box to one side there's a progress box running in the background with blue stripes that are moving but it's been a half hour and my clip is 10 seconds long.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines