Unable to open project: repo.noindex

New Here ,
Jun 28, 2018 Jun 28, 2018

Copy link to clipboard

Copied

Hey there,

I often end up with conflicting copys of files (no, no dropbox etc. only adobe cloud!) but this time the problem seems to be different. Screenshot (47).png

The folder is there and looks pretty normal to me. No conflicting copys or anything.

Screenshot (48).png

Any ideas how to fix this? Don't have a saved puppet file yet because I'm in the middle of working with it.

Also not sure why the sqlite3 file doesn't get a green check.

Views

2.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 28, 2018 Jun 28, 2018

Copy link to clipboard

Copied

I would not run any cloud sync at same time as CH. the lack of tick probably means still syncing (File not complete or upload not complete). The adobe sync does not work well with ch.  You will get frequent errors about files being locked etc. you can suspend sync while in CH, but these days I keep the directories separate and copy the project over to make backups manually.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 05, 2019 May 05, 2019

Copy link to clipboard

Copied

I found a solution to this problem. This happen when the odb.sqlite3 is corrupted. A way to test is download https://sqlitebrowser.org/dl/

Install and open the file odb.sqlite3 with DB Sqlite Browser. If get error like: SQLite database disk is malformed, your file is corrupted. To recovery, you need to download the command line application Sqlite3 at https://www.sqlite.org/2019/sqlite-tools-win32-x86-3280000.zip. Decompress and copy the file odb.sqlite3 in folder that was decompressed. Open a CMD from Windows (or bash shell on Mac), enter in folder and run this command to Dump data from file (sample path):

C:/sqlite_folder/sqlite3.exe odb.sqlite3

Inside Sqlite 3 prompt, run this command to Dump:

sqlite> .mode insert

sqlite> .output dump_all.sql

sqlite> .dump

And exit program with CTRL + C (or command + C on Mac)

Open the file dump_all.sql with any script editor like Notepad++ on Windows or similar on Mac https://notepad-plus-plus.org/download/v7.6.6.html and delete two lines with content only: BEGIN TRANSATION; and ROLLBACK; --due to errors. Save the file.

Very Important, do a backup file renaming odb.sqlite3 file to odb.sqlite3.bkp and open a new odb.sqlite3 file with:

C:/sqlite_folder/sqlite3.exe odb.sqlite3

So read the file .sql to write a new odb.sqlite3 file inside SQLite prompt with:

sqlite> .read dump_all.sql

Wait a long time to write this if your file is big. When done, close the command with CTRL + C.

Copy the odb.sqlite3 file in project, test if open with DB SQLite program without errors. If open, try to open project. With me worked perfect with some errors. So, save it like a new project and back to the fun.

Sorry my english.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 07, 2019 May 07, 2019

Copy link to clipboard

Copied

If you change ROLLBACK to COMMIT instead of removing it and the BEGIN TRANSACTION line, it should run faster (the alternative is that SQLite commits once per insert which can be very slow).

The above technique is similar to one I've used to recover databases. One thing I'll note is that sometimes when the output contains the ROLLBACK due to errors line it means the results are partial, so this may result in a malformed database, but it is definitely worth a shot. If you want me to give fixing it a try as well, feel free to zip it up and send it to me and I"ll see what I can do.

DT

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

LATEST

Hello, I have the same problem. And I do not understand the explanations for this solution (I translate with google translate not being English). Please could you try to fix my project? I have weeks of work on it. 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 01, 2020 Oct 01, 2020

Copy link to clipboard

Copied

How do you open the browser? I can't even see where it installed on my browser.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 01, 2020 Oct 01, 2020

Copy link to clipboard

Copied

These instructions are more geared for developers or those with advanced technical skills. E.g. previously familiarity with GIT for source code version management is useful prior knowledge.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2020 Nov 05, 2020

Copy link to clipboard

Copied

Ok, so I've also been having the same issue....for days. I am just learning how to use character animator, to be honest. I thought I really screwed something up by accident, either through my files or a setting I didn't realize I did. I would open the programme and right off the bat, I'd get the nil value error. I too kept looking around for answers. I tried clearing the history, resetting the workspace. I would try to go to edit and a few other panels, and the damn thing would pop up. (I have 3.1 btw)

I then got an idea. I closed animator. I then located all the project files I had, and deleted them. This was ok for me, because as I was simply messing around this this point, I wasn't losing anything important. I cleared them from my recycle bin, just to be sure. I then reopened animator. I got the this project can't be opened error, so I saved the blank thing as a new project. I am now able to access edit and the other things agskn, so hopefully that fixed it. 

I also want thank oksamurai for his YouTube vids and project downloads. That blank file you put up is crucial when learning how to set up your files. That is what I'm doing now. 

anyway, hope I've helped folks. I feel relieved that I've at least stopped spinnng my own wheels for now, and hopefully got *some* kind of workaround going here!!! Good luck!

 

Ms. Nirmal Singh, of Nirmal in New York (your girl about town lol) 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2020 Nov 06, 2020

Copy link to clipboard

Copied

I tried what you did and it worked but only for a while, now still have the same problem. Any suggestions?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2020 Nov 06, 2020

Copy link to clipboard

Copied

I'd say just keep trying that formula for now. I haven't actually gone back to work on my puppets since I did this, because I had to fix the psd file. I'm trying to see if not having the file(s) structured correctly contributes to the problem. I downloaded ok samurai's blank template, n I'm now restructuring the file to that.

 

https://okaysamurai.com/puppets/

if you need it (page all the way down)

 

If you haven't done that, then perhaps try that. I'm still very much in the figuring everything out process myself. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines