Waiting on Camera in Character Animator

New Here ,
Jul 22, 2019 Jul 22, 2019

Copy link to clipboard

Copied

Hello,

The last two days I have been in contact with support and we have tried everything imaginable without luck. Is anyone else having this issue?

Views

1.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 23, 2019 Jul 23, 2019

Copy link to clipboard

Copied

What is the issue? (Was there a previous thread? You started a new thread with this post but I recall you mentioning it before?)

One thing to check for is under security in Mojave you now have to grant CH permission to use the camera. Sometimes that does not get turned on by default. But if starting facebook first fixes it, that does not sound like the problem.

The other idea is to remove CH software and reinstall. Maybe there is some badly installed driver that reinstalling CH will fix. A few other problems got fixed this way.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 24, 2019 Jul 24, 2019

Copy link to clipboard

Copied

Hi isaacj,

We're sorry for the experience you had. We're here to make it right and help you with the issue. I understand you are unable to use the camera for character Animator. In addition to the questions asked by @alank, I'd like to know:

  • Which Operating system are you using(macOS or Windows)?
  • Are you using an inbuilt camera?
  • Are the drivers for the device updated?

Let me know.

Thanks,

Shivangi

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 14, 2020 Apr 14, 2020

Copy link to clipboard

Copied

I got this message in the Camera & Microphone panel after installing CamTwist which adds camera options.

 

Try changing the current camera in the Camera & Microphone pop-up menu.

 

 

Character Animatior > Camera & Microphone > Camera Setting.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

Hi Warren,

 

Just wondering if you got CamTwist to actually work in CA?  I tried it and the only thing I can get to show up is colorbars with the CamTwist logo (backwards).  That's close but still no video image other than my built-in "Facetime" on my laptop.  Unfortunately that's not very convienient to use because I use a much bigger external monitor and leave my laptop closed on a shelf under my desk.  If I could figure out CamTwist I could use several other camera options that I already own!  Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

I just did a quick test with CamTwist. For a video source in CamTwist I was sharing my desktop. I found "CamTwist" jumpy (the source was flickering and not working well) but the "CamTwist (2VUY)" option worked fine. No idea why, but its a different color encoding I think.

 

Oh, it also failed when I grabbed my external (higher resolution) monitor. CH did not work then. So CH might have an upper bound on resolution it supports perhaps. I did not play with limiting to 12fps etc settings, just sharing that CH can read from CamTwist - but you might need to fiddle with settings.

 

alank99101739_0-1586973253328.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 16, 2020 Apr 16, 2020

Copy link to clipboard

Copied

LATEST

Thank you for your reply Alan.  I too was able to get CamTwist working!  Although it took quite a bit of experimentation and trying of different settings, I finally got it working with the below settings.  My equpiment/signal chain is probably pretty unsual but hopefully this post will help someone trying to do a similar thing in the future.

 

I have a MacBook Pro early 2018 currently running 10.14.6 Mojave.  I use an external monitor with my MacBook typically closed under my desk so I was hoping to use a different camera that I already own.  I tried an older GoPro Hero 2, my Canon DSLR, and what finally worked was my little Canon VIXIA HF R400 camcorder.  I used a Mini HDMI (not micro HDMI) cable and ran that into a Blackmagic Intensity Extreme Thunderbolt interface (driver version 11.5).  Though Character Animator would see the Blackmagic hardware option in the dropdown menu, it just said "waiting on camera" when selected with no image.  I experimented for several hours and what finally worked was setting the camcorder for "1080i 60p".  Then using the Blackmagic Desktop Video setup in the Mac's system preferences, I chose HDMI input and set all "video standard" settings to 1080i 59.94 (on HDMI output as well as the video standard for Final Cut Pro X further down in the menu options; it's Pixel format was 8-bit YUV 4:2:2 but I'm guessing none of that factored in to CA working).  This allowed the Blackmagic Media Express capture software to see the camera's image.  So I knew I was getting somewhere!  

 

Then using the CamTwist software (version 3.4.3), I went to it's preferences and under Video Devices & selected my Blackmagic Thunderbolt hardware and chose 1920x1080 1080i - Uncompressed 8-bit YUV 4:2:2 for format and (curiously) 29.97 for the frame rate.  Then I created a button in CamTwist, selected the camera and made it "live" in CamTwist's Program view.  Then when I went back to Character Animator, the standard CamTwist choice didn't work but the CamTwist 2VUY option did indeed work for me as well!  The image looks great and it tracks my face quite well!

 

I will say that it seems to be quite picky.  When I put my Mac to sleep or closed the software and came back later, I had to go through some of these settings again or sometimes restart the Mac to get the image back.  So it's certainly not an ideal situation if it won't stay "live" and connected all of the time.  But I can report eventual success!  Hope this post helps someone else trying to do the same!  I also encourage readers to donate to the creator of CamTwist if it indeed helps you as well.  Good luck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines