Walk cycle not working. Handles not recognised.

Community Beginner ,
Jan 08, 2019 Jan 08, 2019

Copy link to clipboard

Copied

I am trying to use the walk cycle for this character. Still very much a development stage and to start I just wanted to see how it would respond to the walk cycle. I wasn't expecting great results to start because of the odd body shape. The arms are not really supposed to be there. I just put them in so that I could use all the tagged control points. thought I might make them transparent later if everything basically works  However ... no walk movement at all. I have compared it with the downloadable models tags etc seem OK but when inspecting the handles in the behaviour panel they are not recognised and I don't seem to be able to change this. tThis is obviously the problem but I don't seem to be able to change this.

Link to puppet file   https://drive.google.com/open?id=1baMo2XM1WLClaShUZ7bKEczYMRhF37FW

All help appreciated.

Views

1.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 27, 2019 Feb 27, 2019

Copy link to clipboard

Copied

Were you able to resolve the issue?

The puppet looks like it has Left Profile and Right Profile tags applied to the head, but the Walk behavior is looking for tagged handles for the hips, knees, toes, waist, shoulders, elbows, wrist, etc. If you open the puppet in the Puppet panel, then look in the Properties panel for the Walk behavior, it shows matching Views (for the right quarter and left quarter layers), but under the Handles section it's showing no tagged handles.

Walking example puppets are the Walkbot and Sticky puppets available from the Start workspace.

Also, this video might be useful: New Features - April 2017 (Adobe Character Animator CC Beta) - YouTube

Hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 28, 2019 Feb 28, 2019

Copy link to clipboard

Copied

LATEST

Yup... it's those view tags. When I removed them from the head layers, the walk behavior started recognizing the other walk-related tags.

I've had this happen before because I used the view tags in the "wrong" way. I never fully unraveled why/how the view tags and walk behavior's ability to recognize tags interact in this way. I'll think about that and get back on the matter.

I attached my tweaked version of your puppet. You notice that I added a walk behavior just to the legs layer. I just discovered recently that you can do this. What I do is have two walk cycles: one for the overall puppet and another just for the legs. I found this gives me more control over walking.

Sometimes I want a character to walk without arms or the upper body moving, so I turn off the walk behavior that's on the overall puppet and just run the legs walk cycle. Also, this allows me to control the strength of the walk cycle separately for both parts of the puppet... you'll see when you open it up...

glug

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines