Highlighted

Char Animator no longer reading Illustrator file

Explorer ,
Oct 11, 2017

Copy link to clipboard

Copied

Hi there,

Character Animator has been playing up a fair bit today for me.

My puppet is no longer reading updates from the AI file.

I'm opening the file using Ctrl-E to make sure I'm editing the right file.

I've included screengrabs of the AI file and have added some random black lines at the base to double-check if CA is updating.  Have re-opened, there are more elements missing in the rigging section of CA.  It's not reading any changes to layer names or new additions to the file.  Added to this, the "angry eyebrows" are randomly now appearing off-centre from the eyes.

Screengrabs are included below.  Any advice would be hugely appreciated.

Screenshot (20).png

2 added lines.png

Screenshot (21).png

Views

265

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Char Animator no longer reading Illustrator file

Explorer ,
Oct 11, 2017

Copy link to clipboard

Copied

Hi there,

Character Animator has been playing up a fair bit today for me.

My puppet is no longer reading updates from the AI file.

I'm opening the file using Ctrl-E to make sure I'm editing the right file.

I've included screengrabs of the AI file and have added some random black lines at the base to double-check if CA is updating.  Have re-opened, there are more elements missing in the rigging section of CA.  It's not reading any changes to layer names or new additions to the file.  Added to this, the "angry eyebrows" are randomly now appearing off-centre from the eyes.

Screengrabs are included below.  Any advice would be hugely appreciated.

Screenshot (20).png

2 added lines.png

Screenshot (21).png

Views

266

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Oct 11, 2017

Copy link to clipboard

Copied

PS a link to the puppet is here - Milk puppets.puppet

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Oct 11, 2017

Copy link to clipboard

Copied

For the color bars / missing artwork - were these moved? Or maybe on a cloud-backed directory or external drive? Does keeping them local help at all? Or maybe these files got renamed and just need to be relinked?:

The eyebrow shifting is a bug from Beta 6 - sometimes when you update your artwork, CH has a hard time reconciling the new additions, particularly if your changes adjust the width or height (making the overall puppet size bigger or smaller). You could right-click the layers to try to reset them, and/or move them manually back into place inside CH by dragging them on the canvas with the move tool. I think this is better in the upcoming next reelease...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Oct 12, 2017

Copy link to clipboard

Copied

Thanks for getting back to me.  It's a strange one.  The parts that started showing up missing have had the same name and haven't been moved in quite a few weeks.  They're now no longer appearing to be missing but there is still huge issue with the puppet -

The main thing at the moment is that the puppet simply isn't looking back to the source file and updating when I change the AI file.

I've opened up the file I've uploaded (the puppet file) for this character and dragged it into a new scene.  Again, opening the character with Ctrl-E on a PC, I've changed elements and those changes aren't being read by CA.

If you can take a look at the attached puppet and let me know if you're having the same issue, that would be great. 

Many thanks,

Rob

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Oct 12, 2017

Copy link to clipboard

Copied

Very strange, it's working great for me.

Screen Shot 2017-10-12 at 9.27.02 AM.png

Oh wait - I think I found it - with your puppet selected, make sure "auto sync with artwork" is checked.

Screen Shot 2017-10-12 at 9.35.25 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Abando LATEST
Explorer ,
Oct 15, 2017

Copy link to clipboard

Copied

Thanks so much for this!  I can honestly say I would have never figured this out myself - I was slightly giving up on this.  Really, really appreciate it!

Rob

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...