Highlighted

Character appears with "rip"

Community Beginner ,
Feb 19, 2018

Copy link to clipboard

Copied

I am setting up a new character in Character Animator, and came across a weird problem.

I have the sticks set up on the body level (see image 2).  When I go to preview mode, there appears to be a "rip" or "cut" in my artwork (see image 1).  There is no seam in the actual artwork; the neck is a solid shape.  The torso is a separate solid shape.

rip01.PNG

rip2.PNG

Any help in figuring out why this is happening would be great.

Hey, thanks to your suggestion that it was the artwork, I was able to fix it (though still don't know what caused it).

I started over in rigging the character, checking after each step to see if the "rip" occurred.  In the original artwork, the arms were independent.  As soon as I turned off independence, I noticed that the rip would happen.  So it seemed like it had something to do with the arm art.

I removed the "+" from the arms and noticed that when I pulled it into Ch, the Left Arm artwork wouldn't allow me to turn ON independence.  Very strange.  So I tried making the Left Arm layer order look like the Right Arm layer order.  Still no luck.

So I just deleted the left arm and copy+reflected the right arm in its place.

That seems to have fixed the issue.  I'm still not sure what about the Left Arm artwork was causing the problem.  Nothing about it seems different from the Right Arm artwork (except that I drew it separately).  If I ever figure it out, I'll update. But at least for now the problem is fixed.

Thanks again.

Views

131

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Character appears with "rip"

Community Beginner ,
Feb 19, 2018

Copy link to clipboard

Copied

I am setting up a new character in Character Animator, and came across a weird problem.

I have the sticks set up on the body level (see image 2).  When I go to preview mode, there appears to be a "rip" or "cut" in my artwork (see image 1).  There is no seam in the actual artwork; the neck is a solid shape.  The torso is a separate solid shape.

rip01.PNG

rip2.PNG

Any help in figuring out why this is happening would be great.

Hey, thanks to your suggestion that it was the artwork, I was able to fix it (though still don't know what caused it).

I started over in rigging the character, checking after each step to see if the "rip" occurred.  In the original artwork, the arms were independent.  As soon as I turned off independence, I noticed that the rip would happen.  So it seemed like it had something to do with the arm art.

I removed the "+" from the arms and noticed that when I pulled it into Ch, the Left Arm artwork wouldn't allow me to turn ON independence.  Very strange.  So I tried making the Left Arm layer order look like the Right Arm layer order.  Still no luck.

So I just deleted the left arm and copy+reflected the right arm in its place.

That seems to have fixed the issue.  I'm still not sure what about the Left Arm artwork was causing the problem.  Nothing about it seems different from the Right Arm artwork (except that I drew it separately).  If I ever figure it out, I'll update. But at least for now the problem is fixed.

Thanks again.

Views

132

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Valorous Hero ,
Feb 20, 2018

Copy link to clipboard

Copied

I got something similar sometimes when I used laso to delete some points in a path using Illustrator, resulting in actually breaking the path without realizing it. When I carefully zoomed in on both ends of the rip (I would start at the neck in your example, where the wider gap is), I often found points in the path were not joined up. E.g. if stroke is turned on, you can see the stroke does not continue across all the points. Using pen tool to join up the little gaps solved the problem for me.  Might not be the same problem, but it looks the same as what I saw.

I don’t know how to describe it well because I am still learning Illustrator as well - but I hit the problem quite often when using Adobe Draw to create some artwork, but then trying to simplify and clean up in Illustrator by removing excessive points it had created.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 20, 2018

Copy link to clipboard

Copied

Thanks for the reply.  I've double checked my artwork.  The neck and shirt are in 3 pieces (neck, shirt collar, and shirt).  There doesn't appear to be any break in the paths.  See 2 images below (black outline of neck and black outline for shirt).

rip3.PNG

rip4.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Valorous Hero ,
Feb 20, 2018

Copy link to clipboard

Copied

Hmm. The fact that the rip goes from the neck down over the shirt when you have separate pieces like the above also means its less likely to be the same as my problem. Assuming you have zoomed right in and checked its a closed loop for the neck (not just the start and end "very close" to each other, other suggestions are

(1) in the scene window you can turn the mesh on as well - it might give you a clue to where the distortion is coming from

(2) try changing the hair color and outlines (basically anything black) to see whether that "rip" is actually black getting distorted on top of the shirt (rather than a rip). If you changed all the black to oranges and blues etc, you might get a hint to its source. Also try changing the background color from black to white - if a gap in the puppet, the black should change to white.

The other thing you can do is go into the artwork, try using the laso over the ends of the "rip" and see if there is a hidden object or point there you did not expect. Sometimes a single stray point can get Ch a bit messed up.

Other than that, you need to the true experts here to solve it. A frequent request is to export and upload the puppet file if you don't mind it being public - then people can explore directly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 20, 2018

Copy link to clipboard

Copied

Hey, thanks to your suggestion that it was the artwork, I was able to fix it (though still don't know what caused it).

I started over in rigging the character, checking after each step to see if the "rip" occurred.  In the original artwork, the arms were independent.  As soon as I turned off independence, I noticed that the rip would happen.  So it seemed like it had something to do with the arm art.

I removed the "+" from the arms and noticed that when I pulled it into Ch, the Left Arm artwork wouldn't allow me to turn ON independence.  Very strange.  So I tried making the Left Arm layer order look like the Right Arm layer order.  Still no luck.

So I just deleted the left arm and copy+reflected the right arm in its place.

That seems to have fixed the issue.  I'm still not sure what about the Left Arm artwork was causing the problem.  Nothing about it seems different from the Right Arm artwork (except that I drew it separately).  If I ever figure it out, I'll update. But at least for now the problem is fixed.

Thanks again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...