Highlighted

Character will not stop walking

Community Beginner ,
Oct 28, 2018

Copy link to clipboard

Copied

I have followed the tutorial I believe exactly but I have a huge problem. When I start the record, the puppet disappears from the stage.  and when I stop the record I can't get the puppet to stop walking the keys do not respond.  What am I doing wrong?

Yes. I move the character off stage and can see it, but when I start the record it disappears completely and when I stop the record the puppet returns but the recording playback is blank, and yes I used the right arrow key.

I can not get the puppet to move at all no movement except the stationary walk.

Thanks in advance for any assistance.

John

The walk behavior is confusing and painful, if you have body speed turned on. Basically it walks if the behavior is turned on. If you rewind the playhead, it does NOT rewind the puppet position. If you pause playback at a point where the walk behavior is turned on, the puppet will keep waking! Very confusing!

The easist way to control (in my opinion) is to set body speed to zero and use blends and position x/y recordings to move the body. It does not matter if puppet walks without moving Then.

Otherwise you need to click the refresh button before playback to see how it’s really going to come out. Refresh moves the puppet back to its starting point.

Thd above is the most common problem I hear anyway.

(I think the walk behavior should be computed as a distance from the start of the recording - then playback, rewind etc would all work.)

Views

230

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Character will not stop walking

Community Beginner ,
Oct 28, 2018

Copy link to clipboard

Copied

I have followed the tutorial I believe exactly but I have a huge problem. When I start the record, the puppet disappears from the stage.  and when I stop the record I can't get the puppet to stop walking the keys do not respond.  What am I doing wrong?

Yes. I move the character off stage and can see it, but when I start the record it disappears completely and when I stop the record the puppet returns but the recording playback is blank, and yes I used the right arrow key.

I can not get the puppet to move at all no movement except the stationary walk.

Thanks in advance for any assistance.

John

The walk behavior is confusing and painful, if you have body speed turned on. Basically it walks if the behavior is turned on. If you rewind the playhead, it does NOT rewind the puppet position. If you pause playback at a point where the walk behavior is turned on, the puppet will keep waking! Very confusing!

The easist way to control (in my opinion) is to set body speed to zero and use blends and position x/y recordings to move the body. It does not matter if puppet walks without moving Then.

Otherwise you need to click the refresh button before playback to see how it’s really going to come out. Refresh moves the puppet back to its starting point.

Thd above is the most common problem I hear anyway.

(I think the walk behavior should be computed as a distance from the start of the recording - then playback, rewind etc would all work.)

Views

231

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Valorous Hero ,
Oct 28, 2018

Copy link to clipboard

Copied

The walk behavior is confusing and painful, if you have body speed turned on. Basically it walks if the behavior is turned on. If you rewind the playhead, it does NOT rewind the puppet position. If you pause playback at a point where the walk behavior is turned on, the puppet will keep waking! Very confusing!

The easist way to control (in my opinion) is to set body speed to zero and use blends and position x/y recordings to move the body. It does not matter if puppet walks without moving Then.

Otherwise you need to click the refresh button before playback to see how it’s really going to come out. Refresh moves the puppet back to its starting point.

Thd above is the most common problem I hear anyway.

(I think the walk behavior should be computed as a distance from the start of the recording - then playback, rewind etc would all work.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Enthusiast ,
Oct 29, 2018

Copy link to clipboard

Copied

alank99101739  wrote

(I think the walk behavior should be computed as a distance from the start of the recording - then playback, rewind etc would all work.)

(Off topic) An older animation software I used to use did exactly this- when you set up your walk behavior, you could set a "stride length" that would move the character appropriately while it walks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Valorous Hero ,
Oct 29, 2018

Copy link to clipboard

Copied

I guess it might not work if you cannot walk through walls etc - eg does physics affect position? Then it would not be deterministic...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Oct 28, 2018

Copy link to clipboard

Copied

That did not work, body speed was 0, and I click it read and nothing changed.  What is more frustrating is that the puppet disappears when I click record and then during playback. When I am not recording it is on stage, and walking.  this is getting VERY frustrating.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Valorous Hero ,
Oct 28, 2018

Copy link to clipboard

Copied

That is strange... one quick thing to try is to hold down ALT and click the refresh button at bottom of scene window (two arrows in a circle). That flushes various internal caches.

Otherwise feel free to zip up the project (or just export puppet and share that - easier for us both). Up load to google drive or similar. I cannot think of a reason why the puppet disappears when recording.

i suspect an issue with profiles and tags (eg tags are not right on profiles), but why is it only failing during record?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Oct 29, 2018

Copy link to clipboard

Copied

What is interesting is that this morning it started to work, and I figured out a lot of the problem.  I had the right and left reversed, among other things, and for some reason, two walk behaviors showed up, not sure how that happened.  But once I finally got rid of the extra walk behavior, the walking works great.  Still having a problem with the right foot being slightly too high but at least not it is working the way it should.  Thanks for the help, that put me in the right direction. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...