Highlighted

Clipping mask from illustrator to Ch Animator Situation

Community Beginner ,
Mar 19, 2018

Copy link to clipboard

Copied

So, I have made some clipping masks in illustrator and taken then to Ch without problems(clothing, basically). It gets the clipping group as a single layer, and fine. But I have two arms in wich it is not working. Actually, three, but one got solved just recomposing layers in illustrator. I have tried the same, but it does not work: it gets it as two different layers and therefore the <linked file> in illustrator appears completely, not being the inside of the clipping path. I have tried renaming, reordering...i can´t make it work. Any ideas? Thanks

Oh, just realized my answer might have been not answering your question! I don’t know why the second clipping did not work and the first did.  My understanding is not all Illustrator features are supported by Character Animator - you might have hit one. 

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Clipping mask from illustrator to Ch Animator Situation

Community Beginner ,
Mar 19, 2018

Copy link to clipboard

Copied

So, I have made some clipping masks in illustrator and taken then to Ch without problems(clothing, basically). It gets the clipping group as a single layer, and fine. But I have two arms in wich it is not working. Actually, three, but one got solved just recomposing layers in illustrator. I have tried the same, but it does not work: it gets it as two different layers and therefore the <linked file> in illustrator appears completely, not being the inside of the clipping path. I have tried renaming, reordering...i can´t make it work. Any ideas? Thanks

Oh, just realized my answer might have been not answering your question! I don’t know why the second clipping did not work and the first did.  My understanding is not all Illustrator features are supported by Character Animator - you might have hit one. 

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 19, 2018 1
Valorous Hero ,
Mar 19, 2018

Copy link to clipboard

Copied

Sorry, I don't understand your description, but I thought that Illustrator clipping masks were not understood by Character Animator. It just understands the transparencies in Illustrator files. There is a clipping mask concept inside Character Animator you can turn on, but I suspect you are not using that from your description. Could you share a screen shot perhaps?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 19, 2018 0
Community Beginner ,
Mar 20, 2018

Copy link to clipboard

Copied

Thanks! Maybe I am just getting lucky with this clipping masks??? As you can see, clipping mask are interpreted as one layer in my frontal character, while some are interpreted as one layer in the profile and others as two layers(being a problem). I hid the right arm in the profile character so you can see the torso is alright, but the arms are not working.

By the way, do not judge me by my illustrations, please. I am a video editor but someone asked me if I could draw something.

Captura.JPGCaptura3.JPGCaptura2.JPGCaptura4.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2018 0
Valorous Hero ,
Mar 20, 2018

Copy link to clipboard

Copied

Ah, gotcha!  Character Animator tries to auto-detect the outline, but sometimes fails. It is usually because there is some discontinuous object in the layer. There is a property that you can set to “Contour” to force using the outline instead of the default “auto”. You could try just setting that. 

Otherwise (or as well!) try going into AI/PS, go into isolation mode for the suit, then try using the laso tool around the suit to see if you can highlight something that snuck into the wrong layer.

The other thing to try is clicking the little mesh icon at the bottom of the “rig” and “scene” windows. It shows the mesh it allocated to the layer. This is very important to get right otherwise things will distort badly later. Sometimes it highlights the area that is wrong (the mesh looks funny around a point you did not expect).

Regarding artwork quality, looks good to me! I am a programmers with zero formal art training, so I cannot speak either! ;-).  As long as its fun, who cares what it looks like... which I can say since this is a hobby for me, not work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2018 0
Valorous Hero ,
Mar 20, 2018

Copy link to clipboard

Copied

Oh, just realized my answer might have been not answering your question! I don’t know why the second clipping did not work and the first did.  My understanding is not all Illustrator features are supported by Character Animator - you might have hit one. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2018 1
Community Beginner ,
Mar 20, 2018

Copy link to clipboard

Copied

Thanks! What I did to make it work, suspecting I could have just been lucky, is export to PNG, get rid of the white background in PS and then import that again to the puppet in illustrator. It is not a vector, but playing with the size looks good for Full HD, and the puppet is not vectorizing the movement anyways, so looks good.

Hey, thanks for the support for my artwork : )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2018 0
Community Beginner ,
Oct 03, 2019

Copy link to clipboard

Copied

Hey All, 


I've found what I believe to be a better solution for this! 


Basically use the pathfinder tools crop mask instead of a clipping mask. This will then "cut" your shapes to the size of the clipping mask. Meaning it follows through to character animation with no weirdness!

 

Hope this helps someone in the future, was a frustrating problem. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2019 1
New Here ,
Apr 02, 2020

Copy link to clipboard

Copied

I'll have to try this out. Thanks 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 02, 2020 0
Adobe Employee ,
Apr 02, 2020

Copy link to clipboard

Copied

Looks like you may have figured it out, but here's a small project showing the clipping group in AI *not* being supported in CH and an alternate way of structuring the puppet so that you can get the same results.
https://adobe.ly/39DZFuP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 02, 2020 0