Highlighted

Draggable Arm not working :'(

New Here ,
Aug 03, 2019

Copy link to clipboard

Copied

Huge fan of Adobe Ch! Thanks to the team and the community.

I have a simple puppet in which I'm trying to implement a draggable arm, so she can basically like... pour milk into coffee. But for the life of me, I just can't get it to work! After any hours, I've hit a wall and have decided to ask the community for help.

What I've done:

  • applied the handles
  • created the sticks
  • added the IK behavior

But no matter what I try, when I try to drag the arm around in Scene view it just does absolutely nothing. Other folks have reported getting undesired warping effects... but that's not my problem. It just doesn't work at all.

Below are the relevant screenshots of how I've rigged it up... but for the love of all that is holy, please someone help!

Here is the exported puppet: https://drive.google.com/open?id=1X2eNJ819jqAHOw9DX4XHBytArDqn4GEC

It looks like the Dragger behavior has been removed. Add the Dragger behavior and the arm will start moving. I added it to "Character" for example, but you can add it to the puppet root as well.

Views

244

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Draggable Arm not working :'(

New Here ,
Aug 03, 2019

Copy link to clipboard

Copied

Huge fan of Adobe Ch! Thanks to the team and the community.

I have a simple puppet in which I'm trying to implement a draggable arm, so she can basically like... pour milk into coffee. But for the life of me, I just can't get it to work! After any hours, I've hit a wall and have decided to ask the community for help.

What I've done:

  • applied the handles
  • created the sticks
  • added the IK behavior

But no matter what I try, when I try to drag the arm around in Scene view it just does absolutely nothing. Other folks have reported getting undesired warping effects... but that's not my problem. It just doesn't work at all.

Below are the relevant screenshots of how I've rigged it up... but for the love of all that is holy, please someone help!

Here is the exported puppet: https://drive.google.com/open?id=1X2eNJ819jqAHOw9DX4XHBytArDqn4GEC

It looks like the Dragger behavior has been removed. Add the Dragger behavior and the arm will start moving. I added it to "Character" for example, but you can add it to the puppet root as well.

Views

245

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Valorous Hero ,
Aug 03, 2019

Copy link to clipboard

Copied

It looks like the Dragger behavior has been removed. Add the Dragger behavior and the arm will start moving. I added it to "Character" for example, but you can add it to the puppet root as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 03, 2019

Copy link to clipboard

Copied

It was a fairly obvious detail to miss, but then... they usually are

[Marked as correct answer] thanks for your time my friend!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...