Nested Layer Picker Changing Wrong Layers

Explorer ,
Aug 06, 2020 Aug 06, 2020

Copy link to clipboard

Copied

I am using numerous layer picker behaviors so that a single puppet can be changed to look like a variety of characters.  I'm using nested subgroups, adding them to controls, and grouping similar sets.

I have a Body Style Group for my two body styles heavy and average.  Inside is a Heavy Color group with layers of that heavy body in different colors.  Same for average.  I also have a Head Style group (thin head and flat head) with nested subgroups containing each of the skin colors (white, brown, red).

I created the Head Group first, added the group and subgroups to Controls.  I grouped the controls for skin color.  Everything is working fine at this point.

I did the same for body style and color.  I followed the same procedure.  Even redid it after it didn't work.  The problem is, when I change the body color slider, it changes the head skin color too.  No logical reason why it should do this.

I have unique names for all of my behaviors.  Any thoughts?

TOPICS
Bugs, Rigging

Views

164

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Aug 07, 2020 Aug 07, 2020
In attempting to fix this myself, I added independence to the Body Styles group and its subgroups, then saved my Photoshop file and gave it a better name than "Layer Picker", just in case there was an issue using that as the filename.I imported the new file.  I applied layer picker to the Body Styles group and separately to its subgroups.  I added them all to the percentage offset property in Controls.  Then I grouped my two subgroups in Controls.  And it worked.But, I then added layer picker to...

Likes

Translate

Translate
Explorer ,
Aug 07, 2020 Aug 07, 2020

Copy link to clipboard

Copied

LATEST

In attempting to fix this myself, I added independence to the Body Styles group and its subgroups, then saved my Photoshop file and gave it a better name than "Layer Picker", just in case there was an issue using that as the filename.

I imported the new file.  I applied layer picker to the Body Styles group and separately to its subgroups.  I added them all to the percentage offset property in Controls.  Then I grouped my two subgroups in Controls.  And it worked.

But, I then added layer picker to my Head Shapes group and its two subgroups and followed the same routine to add them to the Controls area.  Everything still working.  Repeated the process for my Hair Styles group.  Upon completion, the body no longer showed in record mode nor could I use the slider to change it.

Scratch all that, I'm an idiot.  My Body Style Shirt Color subgroup includes a white shirt and my scene had a white background.  At this point, I can report everything working fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines