Highlighted

New update has caused havoc on my characters (they now jump!) :(

Explorer ,
Oct 18, 2018

Copy link to clipboard

Copied

Hi Guys

Up until the recent update they were all finally walking perfectly, now all of them have walking issues (jumpings the worst but).

Searched every walking post and tutorial, not to mention spent hours trying to work out the issue.

I've attached the one with the biggest issues/highest jump.

They're all 4 legged characters, although i tried setting them up again and only using the initial walk cycle for the first two legs and they still jump.

I also tried individual walk cycles for each leg but then the body doesn't move at all which is almost as bad haha.

If theres a way to get the body movement going when the individual legs have all the walk cycles, not just the back two (and front two having the master walk cycle) that would also fix the problem.

So frustrating, since the new updates are all epic, except for the walk cycle havoc haha.

Thanks all, really appreciate it

Robbie

Okay, so I reread the post in case I misunderstood (which I often do on first pass!), but stumbled across something else that seems to help. Again, I don't understand why.

I clicked the "independent layer" on your puppet and it stopped bobby up and down. no other changes. And it walks much nicer with full body movement, which you said you liked. So it may be as simple as put the independence flag on the root of the puppets.

After that there was nice body movement and no stupid bobbing up and down.

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

New update has caused havoc on my characters (they now jump!) :(

Explorer ,
Oct 18, 2018

Copy link to clipboard

Copied

Hi Guys

Up until the recent update they were all finally walking perfectly, now all of them have walking issues (jumpings the worst but).

Searched every walking post and tutorial, not to mention spent hours trying to work out the issue.

I've attached the one with the biggest issues/highest jump.

They're all 4 legged characters, although i tried setting them up again and only using the initial walk cycle for the first two legs and they still jump.

I also tried individual walk cycles for each leg but then the body doesn't move at all which is almost as bad haha.

If theres a way to get the body movement going when the individual legs have all the walk cycles, not just the back two (and front two having the master walk cycle) that would also fix the problem.

So frustrating, since the new updates are all epic, except for the walk cycle havoc haha.

Thanks all, really appreciate it

Robbie

Okay, so I reread the post in case I misunderstood (which I often do on first pass!), but stumbled across something else that seems to help. Again, I don't understand why.

I clicked the "independent layer" on your puppet and it stopped bobby up and down. no other changes. And it walks much nicer with full body movement, which you said you liked. So it may be as simple as put the independence flag on the root of the puppets.

After that there was nice body movement and no stupid bobbing up and down.

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Oct 18, 2018

Copy link to clipboard

Copied

Dropbox - Laya_181018.puppet

hopefully that works

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guru ,
Oct 18, 2018

Copy link to clipboard

Copied

I notice you have a Walk behavior at the puppet root, and another walk behavior on each leg. If I disable (click the eye to turn it off) the root walk behavior it stops bobbing up and down. Also if turned on, with "Strength" set to 0 of the root walk behavior it stops bobbing up and down. But if strength is set to 1% or 100%, it jumps up and down a lot, which is strange. (The head warps strangely with strength of 100% as well)

Is your problem as simple as deleting the walk behavior at the root of the puppet? Or setting the strength to zero. You have body speed set to zero, so wondering if its as simple as deleting that root behavior.

If you go into Rig mode and look at the root puppet behavior, then expand the"handles" section, you will notice it does not recognize the legs etc.

I don't know why its happening, not sure if a bug or feature, but hopefully the above gives you some options.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guru ,
Oct 18, 2018

Copy link to clipboard

Copied

I believe oksamurai​ is at Adobe Max, but maybe a short video on animal (4 legged) walk behaviors could be a good one for the tips and tricks series.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guru ,
Oct 18, 2018

Copy link to clipboard

Copied

Okay, so I reread the post in case I misunderstood (which I often do on first pass!), but stumbled across something else that seems to help. Again, I don't understand why.

I clicked the "independent layer" on your puppet and it stopped bobby up and down. no other changes. And it walks much nicer with full body movement, which you said you liked. So it may be as simple as put the independence flag on the root of the puppets.

After that there was nice body movement and no stupid bobbing up and down.

Likes

2 Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Oct 18, 2018

Copy link to clipboard

Copied

Yes, it's a dumb thing that we hope to fix one day, but currently you have to make your top level independent or it can run into issues. If that doesn't solve it let us know.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Oct 18, 2018

Copy link to clipboard

Copied

MAN i'm an idiot haha, i knew it'd be something simple... it didn't affect it initially which is what threw me off!

Thanks so much alank99101739 (and oksamurai​), saved me snapping the screen in two

(excuse the delay, im in sydney!)

Cheers

Rob

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guru ,
Oct 18, 2018

Copy link to clipboard

Copied

"(excuse the delay, im in sydney!)" ... well, since you are a fellow Aussie... okay! Forgiven! 😉

(I grew up in Melbourne, but working in California for the moment.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...