Highlighted

Pupil movement from Illustrator to Animator

Community Beginner ,
Apr 20, 2018

Copy link to clipboard

Copied

Issue:

Only the left eye of my puppet will move. The right one doesn't move at all.

  • I'm 99% sure I've labeled all eye assets correctly and consistently between both eyes -I've tried re-labeling, and recreating the layers entirely.
  • I've tagged everything correctly and consistently between both eyes - I'm pretty sure all is tagged correctly, but regardless, Left matches Right
  • Blinking on both eyes works great, and eyebrows work great.

I've tried camera input, mouse input, and keyboard input, each with the same result.

I've also had a colleague mess with the puppet on his computer, with the same result, and obviously no solution.

I hope there's an answer to this issue, but I also hope Ch makes a clear and detailed tutorial just on Pupils and Clipping masks, and how they differ between Ps and Ai. During my search for answers, there seem to be a lot of pupil problems, and it's such an important feature.

**Not that it should matter, I think, but I built this puppet from scratch, and not from a template. I mention it incase it's informative*

Below are screen shots of my Ai Layers, and Ch rig...

Illustrator.jpg

Animator.jpg

Views

135

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Pupil movement from Illustrator to Animator

Community Beginner ,
Apr 20, 2018

Copy link to clipboard

Copied

Issue:

Only the left eye of my puppet will move. The right one doesn't move at all.

  • I'm 99% sure I've labeled all eye assets correctly and consistently between both eyes -I've tried re-labeling, and recreating the layers entirely.
  • I've tagged everything correctly and consistently between both eyes - I'm pretty sure all is tagged correctly, but regardless, Left matches Right
  • Blinking on both eyes works great, and eyebrows work great.

I've tried camera input, mouse input, and keyboard input, each with the same result.

I've also had a colleague mess with the puppet on his computer, with the same result, and obviously no solution.

I hope there's an answer to this issue, but I also hope Ch makes a clear and detailed tutorial just on Pupils and Clipping masks, and how they differ between Ps and Ai. During my search for answers, there seem to be a lot of pupil problems, and it's such an important feature.

**Not that it should matter, I think, but I built this puppet from scratch, and not from a template. I mention it incase it's informative*

Below are screen shots of my Ai Layers, and Ch rig...

Illustrator.jpg

Animator.jpg

Views

136

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Valorous Hero ,
Apr 20, 2018

Copy link to clipboard

Copied

I might write up my own version of the eye tagging etc because you are right - there are lots of people asking the same questions (and I sometimes find it hard to find the old discussions). In your case I think the problem is the “Pupil Range” tags are on the wrong layers. If you look at the blue boxes, the “Left Pupil Range” and “Left Pupil Size” boxes are different sizes (there are two outlines), so the left eye can move. The right eye however is not the same - they seem to be tagged on the same objects. As a result, the right eye is not allowed to move.

This is normally a matter of the auto tagger getting things wrong. You need to go through each layer one by one and make sure the right things are tagged. I may have a go at writing up more detailed instructions tonight - if I get it done I will try and post here as well. But hopefully the above helps for now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 26, 2018

Copy link to clipboard

Copied

I'm not sure what the bug was, but it was solved by relinking the Ai file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Valorous Hero ,
Apr 26, 2018

Copy link to clipboard

Copied

Sorry! Did I not include link to blog post here? D’oh! https://extra-ordinary.tv/2018/04/21/debugging-character-animator-eyess/

My guess there was an extra stray tag in there by accident, you cleaned up.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...