Highlighted

Walk cycle error help

Community Beginner ,
Oct 22, 2018

Copy link to clipboard

Copied

Hi all,

I'm having some problems with a walk cycle. I've created a seated character and am trying to use the walk cycle as profiles of him looking left and right.

The model previously worked well however for some reason the trigger to look to the characters left isn't working the way I want it to.

Jerry facing phone 3.puppet - Google Drive

Here is the puppet.

When pressing the left arrow key - the character moves in the way I want. However when pressing the right arrow, the frontal view doesn't disappear in the same manner as the other direction?

Would love some help to spot why this problem is apparent! Alternatively - is there a better method to achieve this turning?

Thanks Adobe community!

I found two strange things in the puppet you shared if you wanted to stick with "walk" - the "Right Profile" layer was not hidden, plus there was an extra "Right Profile" tag on the body under the Right Profile layer - it picked that one instead of the parent. Removing that extra tag made it work.

How I debugged it was to use the "Views" of Walk in the properties panel.

See there is a Right Profile/Body? Removing that tag cleared it up.

So now you can use Walk or a Swap Set! (I would have used a swapset as well personally, but using arrows for profiles is easy to remember as well.)

Views

318

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Walk cycle error help

Community Beginner ,
Oct 22, 2018

Copy link to clipboard

Copied

Hi all,

I'm having some problems with a walk cycle. I've created a seated character and am trying to use the walk cycle as profiles of him looking left and right.

The model previously worked well however for some reason the trigger to look to the characters left isn't working the way I want it to.

Jerry facing phone 3.puppet - Google Drive

Here is the puppet.

When pressing the left arrow key - the character moves in the way I want. However when pressing the right arrow, the frontal view doesn't disappear in the same manner as the other direction?

Would love some help to spot why this problem is apparent! Alternatively - is there a better method to achieve this turning?

Thanks Adobe community!

I found two strange things in the puppet you shared if you wanted to stick with "walk" - the "Right Profile" layer was not hidden, plus there was an extra "Right Profile" tag on the body under the Right Profile layer - it picked that one instead of the parent. Removing that extra tag made it work.

How I debugged it was to use the "Views" of Walk in the properties panel.

See there is a Right Profile/Body? Removing that tag cleared it up.

So now you can use Walk or a Swap Set! (I would have used a swapset as well personally, but using arrows for profiles is easy to remember as well.)

Views

319

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 22, 2018 0
Guru ,
Oct 22, 2018

Copy link to clipboard

Copied

That's an interesting use of the walk behavior, but I would use a swap set instead. I removed the walk and added a swap set for the three views. That seems to work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 22, 2018 0
Guru ,
Oct 22, 2018

Copy link to clipboard

Copied

Here is what I get with this swap set

JerrySwap.png

JerryWalk.gif

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 22, 2018 0
Valorous Hero ,
Oct 22, 2018

Copy link to clipboard

Copied

I found two strange things in the puppet you shared if you wanted to stick with "walk" - the "Right Profile" layer was not hidden, plus there was an extra "Right Profile" tag on the body under the Right Profile layer - it picked that one instead of the parent. Removing that extra tag made it work.

How I debugged it was to use the "Views" of Walk in the properties panel.

See there is a Right Profile/Body? Removing that tag cleared it up.

So now you can use Walk or a Swap Set! (I would have used a swapset as well personally, but using arrows for profiles is easy to remember as well.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 22, 2018 0
Community Beginner ,
Oct 23, 2018

Copy link to clipboard

Copied

Thanks for trouble shooting this one alank!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2018 0
Community Beginner ,
Oct 23, 2018

Copy link to clipboard

Copied

Thanks for the contribution too KJerryK!

I recorded a scene and noticed that the characters body disappeared when rendered out. Was looking to recover the recorded session and fixing the walk function did it well for now!

Likely going to swap to a Swap Set once I get this scene out of the way.

Really appreciate the help on this one!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2018 0