• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

500 internal error while accessing Application on Cold Fusion and Admin page of Cold Fusion

Community Beginner ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

"Error","DefaultQuartzScheduler_Worker-3","01/20/22","18:00:00",,"500 Internal Server Error "
coldfusion.tagext.net.HttpTag$HttpTagServerErrorException: 500 Internal Server Error
at coldfusion.tagext.net.HttpTag.connHelper(HttpTag.java:1214)
at coldfusion.tagext.net.HttpTag.runCall(HttpTag.java:1413)
at coldfusion.scheduling.CronTask.execute(CronTask.java:121)
at org.quartz.core.JobRunShell.run(JobRunShell.java:207)
at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:560)

Views

500

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jan 26, 2022 Jan 26, 2022

thanks for the input Charlie! Issue finally got resolved. Security team had removed permissions from drive level, that caused the error.

Votes

Translate

Translate
Community Expert ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

That's not much information. Nevertheless, there is one clue you can follow up: a scheduled-task error. 

 

Could you share the error-message from the exception.log at time "01/20/22","18:00:00"?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

the above error is from exception log only. In addition, here is the IIS error I see 

 

HTTP Error 500.0 - Internal Server Error

Calling LoadLibraryEx on ISAPI filter "D:\ColdFusion11\config\wsconfig\1\isapi_redirect.dll" failed

Detailed Error Information:

ModuleNotificationHandlerError Code
   IIS Web Core
   Unknown
   ExtensionlessUrlHandler-Integrated-4.0
   0x80070005
Requested URLPhysical PathLogon MethodLogon User
   
   D:\ColdFusion11\cfusion\wwwroot
   Not yet determined
   Not yet determined

 

I tried the steps from  https://helpx.adobe.com/coldfusion/kb/troubleshoot-error-500-coldfusion.html , but still getting the error

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

Shambhawi, that error can have many causes, but from my experience helping people the most common are:

  • Someone changed the iis app pool to be 32-bit. See the advanced settings for the app pool of the site in question. 
  • If that's it, watch out also for "default app pool settings" in iis, which would affect newly created app pools--and this may be what caused this app pool to be set that way. Change it to NOT be 32-bit, unless you have a compelling reason otherwise 
  • A different possibility is that someone changed the iis site or application pool to have a user that's different from the default, and they did not give permission for that user to the config/wsconfig folder above
  • Or they removed permissions from that folder (or the 1 subfolder or even the dll)
  • Reconciling those permissions may solve the problem

If it's none of these, do be sure you're not seeing a cached page in your browser. Try another browser.

 

If that's still not it, let us know. 


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

thanks for the input Charlie! Issue finally got resolved. Security team had removed permissions from drive level, that caused the error.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

LATEST

Glad your folks solved it. That problem was a variant of my 4th bullet above: I proposed it could be that it was permissions removed from the specific wsconfig folder, but you're saying they ahd removed permissions from the whole drive. 🙂

 

Besides wondering if you might also mark mine as an answer (in addition to yours, as there can be more than one marked as an answer), I am also concerned for you if their solution was to give the permissions BACK to the whole drive. That may not be needed. Instead they may only need to have given it to that wsconfig folder. If that alone worked, it would indeed be more secure.


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 25, 2022 Jan 25, 2022

Copy link to clipboard

Copied

At what time does the IIS error occur? I ask because this error seems to be different from the first.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 25, 2022 Jan 25, 2022

Copy link to clipboard

Copied

@ShambyJ , have you looked into the scheduled-task idea? For example,

  1.  Open lib/neo-cron.xml in a text editor and check whether it is corrupt.
  2.  Test with the back-up neo-cron file. If you have one, it will be called neo-cron.bak.
         Proceed as follows:
         Stop the ColdFusion instance.
         Rename the current neo-cron.xml to neo-cron.original. 
         Rename neo-cron.bak to neo-cron.xml.
         Restart the ColdFusion instance.
         Does that help?

    Some questions to provide context:

What Update level of CF11 are you on?

What Java version are you using for CF11?

Do you have just one IIS site on the server?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation