• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Application Error

Explorer ,
Aug 01, 2019 Aug 01, 2019

Copy link to clipboard

Copied

Hello,

  We are using ColdFusion 2018 on a Windows server 2016 platform. One of our data entry screen crashes when the data is submitted. I see an error message which states something as shown below.

I tried changing the setting for 'postSizeLimit' in the file neo-runtime.xml as it was mentioned in one of the previous posts, this also did not help, we continue to get the same error.

How to resolve this issue ?

HTTP Status 400 – Bad Request


Type Status Report

Message POST parameters exceeds the maximum limit.

Description The server cannot or will not process the request due to something that is perceived to be a client error (e.g., malformed request syntax, invalid request message framing, or deceptive request routing).


Apache Tomcat/9.0.5

Views

832

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 01, 2019 Aug 01, 2019

Copy link to clipboard

Copied

Hello, IQ1.

Did you restart the CF service after changing the post limit?  Did you use the CFAdmin interface, as well, to make sure that the value was changed?

We have to follow STIG requirements, and the STIG states that the default value of 100 should be maintained.  One thing I did to get around this was to use jQuery to .serializeArray() the form, turn it into a JSON string, and place it all in one hidden field, then use .post() to submit the form in the background to a .cfc function to process.  Could that help?

V/r,

^ _ ^

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 01, 2019 Aug 01, 2019

Copy link to clipboard

Copied

I changed the setting to 500 and it worked for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 01, 2019 Aug 01, 2019

Copy link to clipboard

Copied

Glad to hear you got it working. 

V/r,

^ _ ^

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 01, 2019 Aug 01, 2019

Copy link to clipboard

Copied

LATEST

To be clear, if you were getting the error, "POST parameters exceeds the maximum limit", then you would not have needed to change the postSizeLimit limit. Instead, it would be the postParametersLimit. The former is about the max SIZE of something that can be uploaded, while the latter is about the max NUMBER of form fields that can be posted.

Also, since about CF10, you have been able to make the change to BOTH in the CF Admin, without needing to edit the XML file any more.

So when you say now that you "changed the setting to 500", which setting was it? 🙂


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation