• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

ColdFusion 2021 JRE libraries are missing or not compatible

Community Beginner ,
Mar 05, 2023 Mar 05, 2023

Copy link to clipboard

Copied

Hi All,

I'm trying to install CF2021 on RedHat 8.7

The installer keeps exiting with the error:

"JRE libraries are missing or not compatible

 Initially I thought perhaps my /tmp was not large enough so I enlarged it.

Then thought to set IATEMP to another location with tons of space --still the same error.

I even installed a JRE for the system --still the same error

Is this a problem with running RHEL 8.7 vs 8.5?

Is there something else I should be trying?

 

Views

616

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Mar 07, 2023 Mar 07, 2023

Thanks Vikram I was able to install using the LAX_VM and (for good measure) IATEMPDIR.

 

Just wondering why this issue crops up?

 

Dan Mather

Votes

Translate

Translate
Adobe Employee ,
Mar 05, 2023 Mar 05, 2023

Copy link to clipboard

Copied

Hi Dan,

 

Can you please try these steps?

 

1. Type these commands in the terminal: tmp folder location can be anywhere, it is just for reference. 

a.   sudo su

b.   cd /

c.    mkdir tmp2

d.  IATEMPDIR=/home/rhel/tmp
e.  export IATEMPDIR

Thanks,
Priyank Shrivastava

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 06, 2023 Mar 06, 2023

Copy link to clipboard

Copied

Priyank,

Yes, I had tried that -I mistyped the variable name in my initial post.  It was IATEMPDIR that I set to another directory with tens of gigabytes of space.

 

Dan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 07, 2023 Mar 07, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 07, 2023 Mar 07, 2023

Copy link to clipboard

Copied

@Dan Mather,  Could you please try this?

 

./ColdFusion_2021_XXXX_XXXX.bin  LAX_VM  /usr/jdk/xxxx/jre/bin/java

Thanks,

Vikram

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 07, 2023 Mar 07, 2023

Copy link to clipboard

Copied

Thanks Vikram I was able to install using the LAX_VM and (for good measure) IATEMPDIR.

 

Just wondering why this issue crops up?

 

Dan Mather

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 07, 2023 Mar 07, 2023

Copy link to clipboard

Copied

@Dan Mather Glad it worked! One possible reason could be InstallAnywhere picking the incorrect java version. 

 

Thanks,

Vikram

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 07, 2023 Mar 07, 2023

Copy link to clipboard

Copied

LATEST

Can I pile on here?  My rhel8.7 server has both IPv6 and IPv4 enabled. It seems ColdFusion and Tomcat are both picking IPv6 instead of IPv4.  I added Java options to the jvm.config "-Djava.net.preferIPv4Stack=true -Djava.net.preferIPv4Addresses=true" but they don't seem to have any effect.  Is there another way to have ColdFusion builtin web server use IPv4?

 

Thanks,

Dan Mather

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation