• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Configure ColdFusion2018 Performance Monitoring Toolset over https and Apache

New Here ,
Sep 25, 2018 Sep 25, 2018

Copy link to clipboard

Copied

Hi there,

I was able to successfully install CF2018 PerformanceMonitoringToolset in the server. But its not able to discover the server, automatically, as the application server is running over https(port 443). Is there anyway to configure the Performance Monitoring Tool to run over https and to use Apache? I couldn't find its configuration files.

Thank you,

Annie

Views

801

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 25, 2018 Sep 25, 2018

Copy link to clipboard

Copied

Hi Annie,

As of now, we do not support SSL to be configured with PMT Dashboard. We have an enhancement logged for the same and will be fixing it soon.

Thanks,

Priyank Shrivastava

Thanks,
Priyank Shrivastava

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 05, 2019 Feb 05, 2019

Copy link to clipboard

Copied

Any word on whether this issue was fixed, or if it will be in an upcoming update?


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 05, 2019 Feb 05, 2019

Copy link to clipboard

Copied

Also, can Annie or Priyank clarify if this is referring to whether this failure to auto-discover the instance is related to SSL having been configured specifically for the CF Administrator of the instance in question? Is that how the auto-discovery is finding (or failing to find) the instance?

(Some readers may misinterpret this discussion of SSL as being somehow related to whether the application web sites of the instance were configured to be served via SSL, which would not seem to matter.)


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Hi Charlie,

I can answer the first question, SSL configurations have been set up for that fusion instance in CF admin and there are no other instances set up there. Hope that helps. The second question is out of my scope, I'm afraid.

Annie

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Hi Charlie,

SSL configured at web server has nothing to do with PMT configuration. It is only looking for instances when we check the Autodiscovery, the issue which I logged when we configure CF Admin(internal tomcat) configured with SSL. It won't find the instance in Autodiscovery and if we add this manually, it will throw an error.

This has been taken care of and fix will be available soon.

Thanks,

Priyank Shrivastava

Thanks,
Priyank Shrivastava

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 14, 2019 Feb 14, 2019

Copy link to clipboard

Copied

Priyank,

With the new ColdFusion2018 Update 2, the issue is still persisting. I was not able to add the server manually though there was a flag to select https.

I have another question. Does the PMT always run over http? As we generally disable port 80 in our servers. Could you please confirm this?

Thank You,

Annie

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 14, 2019 Feb 14, 2019

Copy link to clipboard

Copied

LATEST

Hi Annie,

Yes, now with this update for PMT and ColdFusion. You can configure SSL on PMT admin and also configure SSL configured ColdFusion nodes to PMT. Here is the screenshot.

Once you apply the update in ColdFusion 2018, please go to C:\ColdFusion2018\cfusion\hf-updates\hf-2018-00002-313961\PMT-hotfix and copy the hotfix.jar to the machine where you have PMT installed. i.e. C:\ColdFusion2018PerformanceMonitoringToolset\jre\bin

- Launch the command prompt as Admin and navigate to C:\ColdFusion2018PerformanceMonitoringToolset\jre\bin and type the command "java -jar hotfix.jar"

- Follow the onscreen instructions and configure the SSL as per below screenshot.

Thanks,

Priyank Shrivastava

Thanks,
Priyank Shrivastava

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation